summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 06:26:04 +0000
committerSam James <sam@gentoo.org>2021-10-31 06:29:08 +0000
commitcae650d89e8ff3ceb61818bc90b216339deff77d (patch)
treee72adbfcb47e396f7482b15881f460ad5fef92da
parentmedia-gfx/exiv2: enable py3.10 (diff)
downloadgentoo-cae650d89e8ff3ceb61818bc90b216339deff77d.tar.gz
gentoo-cae650d89e8ff3ceb61818bc90b216339deff77d.tar.bz2
gentoo-cae650d89e8ff3ceb61818bc90b216339deff77d.zip
media-gfx/alembic: force use of OpenEXR 2 (ilmbase), not imath for now
We want to avoid mismatches within Blender. Closes: https://bugs.gentoo.org/818232 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/alembic/alembic-1.8.3-r1.ebuild (renamed from media-gfx/alembic/alembic-1.8.3.ebuild)17
-rw-r--r--profiles/arch/arm/package.use.mask4
-rw-r--r--profiles/arch/arm64/package.use.mask4
3 files changed, 16 insertions, 9 deletions
diff --git a/media-gfx/alembic/alembic-1.8.3.ebuild b/media-gfx/alembic/alembic-1.8.3-r1.ebuild
index 5cf7be6360aa..3ec597c047e8 100644
--- a/media-gfx/alembic/alembic-1.8.3.ebuild
+++ b/media-gfx/alembic/alembic-1.8.3-r1.ebuild
@@ -3,15 +3,15 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit cmake python-single-r1
DESCRIPTION="Open framework for storing and sharing scene data"
HOMEPAGE="https://www.alembic.io/"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="examples hdf5 python test"
@@ -20,13 +20,8 @@ RESTRICT="!test? ( test )"
RDEPEND="
${PYTHON_DEPS}
- || (
- >=dev-libs/imath-3.0.1[python?,${PYTHON_SINGLE_USEDEP}]
- (
- >=media-libs/ilmbase-2.5.5
- python? ( >=dev-python/pyilmbase-2.5.5[${PYTHON_SINGLE_USEDEP}] )
- )
- )
+ >=media-libs/ilmbase-2.5.5:=
+ python? ( >=dev-python/pyilmbase-2.5.5[${PYTHON_SINGLE_USEDEP}] )
hdf5? (
>=sci-libs/hdf5-1.10.2:=[zlib(+)]
>=sys-libs/zlib-1.2.11-r1
@@ -50,6 +45,10 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
+ # Force falling back to ilmbase for now
+ # bug #818232
+ -DCMAKE_DISABLE_FIND_PACKAGE_Imath=ON
+
-DALEMBIC_BUILD_LIBS=ON
-DALEMBIC_SHARED_LIBS=ON
# currently does nothing but require doxygen
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index 88a8463a0774..fa5842d8a528 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2021-10-31)
+# dev-python/pyilmbase isn't keyworded on arm
+media-gfx/alembic python
+
# Sam James <sam@gentoo.org> (2021-10-26)
# Avoid dragging in obscure parts of dev-qt/* unless/until
# somebody needs them. bug #816981.
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index 4dbdd22f3d18..badf15963e1c 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2021-10-31)
+# dev-python/pyilmbase isn't keyworded on arm64
+media-gfx/alembic python
+
# Ben Kohler <bkohler@gentoo.org> (2021-10-18)
# missing keywords on net-misc/pyhoca-cli and its deps
net-misc/remmina x2go