summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-08-20 14:24:55 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-20 14:24:55 -0400
commitd7bd5c1f06f791d5d354ca75100ed64204eea8bd (patch)
tree7c6ce9c541a21ee0329f5a20479aef96638d7a5d
parentx11-libs/libdrm: Drop old versions (diff)
downloadgentoo-d7bd5c1f06f791d5d354ca75100ed64204eea8bd.tar.gz
gentoo-d7bd5c1f06f791d5d354ca75100ed64204eea8bd.tar.bz2
gentoo-d7bd5c1f06f791d5d354ca75100ed64204eea8bd.zip
dev-libs/rocr-runtime: Add nonfree flag for optional HSA image support
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/rocr-runtime/metadata.xml3
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-2.7.0.ebuild7
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-9999.ebuild9
3 files changed, 14 insertions, 5 deletions
diff --git a/dev-libs/rocr-runtime/metadata.xml b/dev-libs/rocr-runtime/metadata.xml
index d53b83185ad3..53844ebc13ea 100644
--- a/dev-libs/rocr-runtime/metadata.xml
+++ b/dev-libs/rocr-runtime/metadata.xml
@@ -15,4 +15,7 @@
<longdescription lang="en">
Radeon Open Compute Platform Runtime
</longdescription>
+ <use>
+ <flag name="nonfree">Enables HSA image support using <pkg>dev-libs/hsa-ext-rocr</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/dev-libs/rocr-runtime/rocr-runtime-2.7.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-2.7.0.ebuild
index b2fdce8bee32..507d471dc104 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-2.7.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-2.7.0.ebuild
@@ -23,9 +23,12 @@ PATCHES=(
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
+IUSE="nonfree"
-RDEPEND="sys-process/numactl"
-DEPEND="${RDEPEND}
+COMMON_DEPEND="sys-process/numactl"
+RDEPEND="${COMMON_DEPEND}
+ nonfree? ( dev-libs/hsa-ext-rocr )"
+DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}"
src_prepare() {
diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
index a31193337a6d..6a89ca2901eb 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
@@ -20,10 +20,13 @@ HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
+IUSE="nonfree"
-RDEPEND="sys-process/numactl"
-DEPEND="${RDEPEND}
- dev-libs/roct-thunk-interface"
+COMMON_DEPEND="sys-process/numactl"
+RDEPEND="${COMMON_DEPEND}
+ nonfree? ( dev-libs/hsa-ext-rocr )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die