summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-02-20 17:35:51 +0300
committerSam James <sam@gentoo.org>2023-03-11 16:25:50 +0000
commitda23c443933f51b4a9fd9ff98175f804dc52af37 (patch)
tree7334f9882835e53840f06700560857d5ea841b04
parentdev-util/rocminfo: enable release build (diff)
downloadgentoo-da23c443933f51b4a9fd9ff98175f804dc52af37.tar.gz
gentoo-da23c443933f51b4a9fd9ff98175f804dc52af37.tar.bz2
gentoo-da23c443933f51b4a9fd9ff98175f804dc52af37.zip
net-vpn/openvpn: fix crushing multiple instances
In environment with multiple openvpn's instances if one of them get crushed, trying to restart it will result to stoping ALL of other openvpn instances. Introduced `--config "${VPNCONF}"` option to prevent it as suggested by Zhixu Liu. Closes: https://bugs.gentoo.org/829949 Suggested-by: Zhixu Liu <zhixu.liu@gmail.com> Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29685 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-vpn/openvpn/files/openvpn-2.1.init5
-rw-r--r--net-vpn/openvpn/openvpn-2.5.2-r3.ebuild (renamed from net-vpn/openvpn/openvpn-2.5.2-r2.ebuild)0
-rw-r--r--net-vpn/openvpn/openvpn-2.5.6-r1.ebuild (renamed from net-vpn/openvpn/openvpn-2.5.6.ebuild)0
-rw-r--r--net-vpn/openvpn/openvpn-2.5.7-r1.ebuild (renamed from net-vpn/openvpn/openvpn-2.5.7.ebuild)0
4 files changed, 3 insertions, 2 deletions
diff --git a/net-vpn/openvpn/files/openvpn-2.1.init b/net-vpn/openvpn/files/openvpn-2.1.init
index ba05689a1e09..3af33f5e6392 100644
--- a/net-vpn/openvpn/files/openvpn-2.1.init
+++ b/net-vpn/openvpn/files/openvpn-2.1.init
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
VPNDIR=${VPNDIR:-/etc/openvpn}
@@ -126,7 +126,8 @@ stop() {
ebegin "Stopping ${SVCNAME}"
start-stop-daemon --stop --quiet \
- --exec /usr/sbin/openvpn --pidfile "${VPNPID}"
+ --exec /usr/sbin/openvpn --pidfile "${VPNPID}" \
+ -- --config "${VPNCONF}"
eend $?
}
diff --git a/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild b/net-vpn/openvpn/openvpn-2.5.2-r3.ebuild
index de73a33181b3..de73a33181b3 100644
--- a/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
+++ b/net-vpn/openvpn/openvpn-2.5.2-r3.ebuild
diff --git a/net-vpn/openvpn/openvpn-2.5.6.ebuild b/net-vpn/openvpn/openvpn-2.5.6-r1.ebuild
index 3942cd63a328..3942cd63a328 100644
--- a/net-vpn/openvpn/openvpn-2.5.6.ebuild
+++ b/net-vpn/openvpn/openvpn-2.5.6-r1.ebuild
diff --git a/net-vpn/openvpn/openvpn-2.5.7.ebuild b/net-vpn/openvpn/openvpn-2.5.7-r1.ebuild
index 54dbaa5b93e0..54dbaa5b93e0 100644
--- a/net-vpn/openvpn/openvpn-2.5.7.ebuild
+++ b/net-vpn/openvpn/openvpn-2.5.7-r1.ebuild