summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-01 09:38:17 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-01 10:16:17 -0400
commite66b9fb7165acbbf4d7056ea9c93cf791aa806ff (patch)
tree9a0a4e7094c670c9e32a9375daa77376541037c9
parentdev-python/python-debian: Enable py3.12 (diff)
downloadgentoo-e66b9fb7165acbbf4d7056ea9c93cf791aa806ff.tar.gz
gentoo-e66b9fb7165acbbf4d7056ea9c93cf791aa806ff.tar.bz2
gentoo-e66b9fb7165acbbf4d7056ea9c93cf791aa806ff.zip
dev-util/apitrace: use pkg-config for waffle
Just a quick drive-by workaround as better-than-broken, haven't really looked at this package nor upstream. Still needs a bump, but I won't be looking at that. Closes: https://bugs.gentoo.org/901365 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-util/apitrace/apitrace-9.0-r3.ebuild1
-rw-r--r--dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch14
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-util/apitrace/apitrace-9.0-r3.ebuild b/dev-util/apitrace/apitrace-9.0-r3.ebuild
index 1801bf986786..bf951a975ea6 100644
--- a/dev-util/apitrace/apitrace-9.0-r3.ebuild
+++ b/dev-util/apitrace/apitrace-9.0-r3.ebuild
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}"/${P}-disable-multiarch.patch
"${FILESDIR}"/${P}-brotli-unbundle.patch
"${FILESDIR}"/${P}-libc-dlopen-glibc-2.34.patch
+ "${FILESDIR}"/${P}-pkgconfig-waffle.patch
)
src_prepare() {
diff --git a/dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch b/dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch
new file mode 100644
index 000000000000..6d0450886672
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch
@@ -0,0 +1,14 @@
+waffle's upstream intentionally does not ship cmake files anymore
+(just a quick fix that works for us, there may be more to consider)
+
+https://bugs.gentoo.org/901365
+https://gitlab.freedesktop.org/mesa/waffle/-/issues/74
+https://gitlab.freedesktop.org/mesa/waffle/-/commit/a16983fea590491727c8119256c7b938fe1f9d10
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -195,3 +195,4 @@
+ # Use Waffle for eglretrace
+- find_package (Waffle REQUIRED)
++ find_package(PkgConfig REQUIRED)
++ pkg_check_modules(Waffle REQUIRED waffle-1)
+ endif ()