summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-09-03 18:37:23 -0400
committerMatt Turner <mattst88@gentoo.org>2024-09-03 19:51:45 -0400
commitfd05ae0c608c2ab449d5af8dfe66321094dd94a8 (patch)
tree45a8ea41be4a5afa5c7c611e2c324dd521c14ae3
parentmedia-sound/owntone: bump to a git snapshot for MPD fixes (diff)
downloadgentoo-fd05ae0c608c2ab449d5af8dfe66321094dd94a8.tar.gz
gentoo-fd05ae0c608c2ab449d5af8dfe66321094dd94a8.tar.bz2
gentoo-fd05ae0c608c2ab449d5af8dfe66321094dd94a8.zip
dev-libs/libevdev: Version bump to 1.13.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/libevdev/Manifest1
-rw-r--r--dev-libs/libevdev/libevdev-1.13.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libevdev/Manifest b/dev-libs/libevdev/Manifest
index 5a159c4f9f74..afdb2cef1b53 100644
--- a/dev-libs/libevdev/Manifest
+++ b/dev-libs/libevdev/Manifest
@@ -1 +1,2 @@
DIST libevdev-1.13.2.tar.xz 460456 BLAKE2B bdb71525600e2aa3aa264da322e1d7e93270790a48b62baf3df51cf23a6ddf7371cb9de157dd430e632514d1cb3d3b076f8710c43fac4f99e42e7ca503061bee SHA512 558267df0e45d8641a58dddb9fe30e2235ce247d96710189b09512d19d691afbd25189d188bb26bb5092fbbe249fbc7ca60a9e6af4fab535a946d5a3e030a21f
+DIST libevdev-1.13.3.tar.xz 460660 BLAKE2B d4a808ad13e7e5b818bde0b885eb53e109afb0d0ec9b72a80a05a36135c3db955efd092b8f91f0f2393a1f717e2517ed916326dbb32eae13275b89ee0f40003a SHA512 24330c7f6f003c95da97dcb66fcc750437db59ac9049415c35cbcaa1612845363a59180da6b3120c81d7d3f969adb139fa023ed765223e185fb68465d45a0fd2
diff --git a/dev-libs/libevdev/libevdev-1.13.3.ebuild b/dev-libs/libevdev/libevdev-1.13.3.ebuild
new file mode 100644
index 000000000000..41612867b124
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.13.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit meson-multilib python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-text/doxygen )
+ virtual/pkgconfig
+"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ meson_src_test -t 100
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local HTML_DOCS=( doc/html/. )
+ einstalldocs
+ fi
+}