summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-06 17:57:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-06 18:02:08 +0100
commitfee70bffb2d1a7229b1cf4f7fdaa23383aa197c8 (patch)
treea0af8df5e8285a223603dd43013213b2544b4a8e
parentdev-python/pytest-shell-utilities: Enable py3.12 (diff)
downloadgentoo-fee70bffb2d1a7229b1cf4f7fdaa23383aa197c8.tar.gz
gentoo-fee70bffb2d1a7229b1cf4f7fdaa23383aa197c8.tar.bz2
gentoo-fee70bffb2d1a7229b1cf4f7fdaa23383aa197c8.zip
dev-python/pyre2: Modernize, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyre2/Manifest1
-rw-r--r--dev-python/pyre2/pyre2-1.0.7-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyre2/Manifest b/dev-python/pyre2/Manifest
index bb8cbe40825f..343007200f7c 100644
--- a/dev-python/pyre2/Manifest
+++ b/dev-python/pyre2/Manifest
@@ -1 +1,2 @@
+DIST pyre2-1.0.7.gh.tar.gz 11684 BLAKE2B 748a409aa56dab0e088961bdd0b8659dfe0ed817ed1f6fe1dce15fd03e32b30472776c4e21a4f39e66aa5b3539650a657c36acf8b857332b255a139ef0f890a9 SHA512 c4579bf73af2f0a5ccbb6a28b87ce777ef08199947c1bdf740b426960f41b3530c97a7158fac7768b51c92b8a3797f8e66de61e0c942f239920bd5397d63e2c4
DIST pyre2-1.0.7.tar.gz 11684 BLAKE2B 748a409aa56dab0e088961bdd0b8659dfe0ed817ed1f6fe1dce15fd03e32b30472776c4e21a4f39e66aa5b3539650a657c36acf8b857332b255a139ef0f890a9 SHA512 c4579bf73af2f0a5ccbb6a28b87ce777ef08199947c1bdf740b426960f41b3530c97a7158fac7768b51c92b8a3797f8e66de61e0c942f239920bd5397d63e2c4
diff --git a/dev-python/pyre2/pyre2-1.0.7-r1.ebuild b/dev-python/pyre2/pyre2-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..75ab7c25b76c
--- /dev/null
+++ b/dev-python/pyre2/pyre2-1.0.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for dev-libs/re2"
+HOMEPAGE="
+ https://github.com/facebook/pyre2/
+ https://pypi.org/project/fb-re2/
+"
+SRC_URI="
+ https://github.com/facebook/pyre2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/re2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest