summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-15 22:53:56 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-16 09:55:10 -0400
commit5f53dbd6647683c5bffb423fa845fd4469bf15da (patch)
treef4a6405b991c6e3808b5c77d55df84045453239e /app-accessibility
parentgui-libs/libadwaita: Version bump to 1.4.0 (diff)
downloadgentoo-5f53dbd6647683c5bffb423fa845fd4469bf15da.tar.gz
gentoo-5f53dbd6647683c5bffb423fa845fd4469bf15da.tar.bz2
gentoo-5f53dbd6647683c5bffb423fa845fd4469bf15da.zip
app-accessibility/at-spi2-core: Version bump to 2.50.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32821 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.50.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index 00559aa222aa..ba539514b7b0 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.48.3.tar.xz 554388 BLAKE2B 9692df8cc0bc8de82f6e339b9358be7ab1bc598afdb39503f5f05ca772109b962a513fe2ef79d8f094ea732457225409f3c765784a54cbabf27b8fc72c893eb9 SHA512 e79ef0eb0f23241d61ba2a62f4024a5df5ff7125bc085590f9038b3397d255b88b8266deec14f3fe53bee4072ab85695a47d27d8be0529b18a103ad792fa0e54
DIST at-spi2-core-2.48.4.tar.xz 554916 BLAKE2B 6329407e1e0d0a085189174ad31ac65d890e36a1b20179d68155fffa029b476a6b094765b6d3c300a8fa3cdeb01936a1b14cac34c530650287e711132c136ddc SHA512 fa85b680ad5254a8281197969f335c69b6c71d3ea4ec04efb8d70ba9feafd76330cd23a09169eef6f04abf0000e4823d2c2591999e8ed88bc035a26ed8bebdf0
+DIST at-spi2-core-2.50.0.tar.xz 567664 BLAKE2B 18b9c84542bffc13e762e770da08f289358b5987b27c0159818c6f1f09981be029a8f15ce2b7dd6ed99b049ad7e4a4cbbf2bc4d5e97a81d9096b247df218328f SHA512 7de02efa7e3cb9db4a7da8bb2e9350dc00458e2ba9bf9dafb68d2cab8512b525fc7dcecb45f5912de7459b86d901ab3a188f0a07f5bdc068a51433c900de2308
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.50.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.50.0.ebuild
new file mode 100644
index 000000000000..3c6f7560662b
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.50.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility https://gitlab.gnome.org/GNOME/at-spi2-core"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="X dbus-broker gtk-doc +introspection systemd"
+REQUIRED_USE="
+ dbus-broker? ( systemd )
+ gtk-doc? ( X )
+"
+
+DEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.67.4:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ systemd? ( sys-apps/systemd[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+
+ !<dev-libs/atk-2.46.0
+ !<app-accessibility/at-spi2-atk-2.46.0
+"
+RDEPEND="${DEPEND}
+ dbus-broker? ( sys-apps/dbus-broker )
+"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-python/sphinx
+ dev-util/gdbus-codegen
+ >=dev-util/gi-docgen-2021.1
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_bus=$(usex dbus-broker dbus-broker dbus-daemon)
+ $(meson_use systemd use_systemd)
+ -Dgtk2_atk_adaptor=true
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ $(meson_native_use_bool gtk-doc docs)
+ $(meson_native_use_feature introspection)
+ $(meson_feature X x11)
+ -Ddisable_p2p=false
+ -Datk_only=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/{libatspi,atk} || die
+ mv "${ED}"/usr/share/doc/libatspi "${ED}"/usr/share/gtk-doc/libatspi/html || die
+ mv "${ED}"/usr/share/doc/atk "${ED}"/usr/share/gtk-doc/atk/html || die
+ fi
+}