summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-16 05:20:02 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-16 06:10:54 +0100
commitd55c7b0cb836fa32a481e5108ea19a36e3f06f4f (patch)
treea84d33331bf4398f22287c9bb914456a16ce7d81 /app-admin/awscli
parentdev-python/boto3: Bump to 1.36.0 (diff)
downloadgentoo-d55c7b0cb836fa32a481e5108ea19a36e3f06f4f.tar.gz
gentoo-d55c7b0cb836fa32a481e5108ea19a36e3f06f4f.tar.bz2
gentoo-d55c7b0cb836fa32a481e5108ea19a36e3f06f4f.zip
app-admin/awscli: Bump to 1.37.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.37.0.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 254f5d678c31..a6d916a163d8 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.36.33.gh.tar.gz 2877337 BLAKE2B 0e3cdbac864370c0ef785191fc692e1a2
DIST aws-cli-1.36.38.gh.tar.gz 2879388 BLAKE2B 2780cfeb9e6ca61635638ad3df9a0e6cb81eeeb45d7573f5033f37a2366c907e1cc4661766a72d4b45ced5e52d5dae82bd61c2dec455a6e5763ae2605b1e8f0f SHA512 626b606d86cb877c562031c23da57385b5014046d97cbf6cb3f6e73bb528755ff4a12190211feffbe326533500d988e93f55090f242b2b49ae725fc509575780
DIST aws-cli-1.36.39.gh.tar.gz 2879615 BLAKE2B 54bed9cb8e5cb2d5f27178040a4f5f38fb9233a3be3531003c0a91a254185389a2508195520bfb43e7c9666e966ca66ab909d38cd09365cd1014ad541ddf3dd8 SHA512 752e80bae33456057b9c8ddc4e4fd0f97c522cae59d2e6749f549268b0ec9c7d4dd32c797962dd6e0282fd8ced4c3a1ce4f002af96af32c62faefd499f862e4d
DIST aws-cli-1.36.40.gh.tar.gz 2879864 BLAKE2B f6d8ae65edb2f3bb6f15376560f5ad93936f81b1a14d6573af011e9b4fb48552888f52a5b25a29237dc66d54802babec3bd9df640119b10c713b9de7dc6fe7d0 SHA512 1c0de5ff22cd5be7d33dbf0ae3fbe11d7eb5ced13773d8567dee3f57f62aaa7f135555234c659fd33ac0ae9e1c55f95e34ac0b1490e1b7f983ce9cc4a8953809
+DIST aws-cli-1.37.0.gh.tar.gz 2881507 BLAKE2B 4c6fc8921304d8f4c9cf4ce760325be42c2f7b9f072946bba1bd9e9c4d9b28d4033c39bb69b553f6c7a3b07014091d1cffffb4cb9a40bbd22ec4410b06006199 SHA512 170ba977abb2b655346cb1c507126a341e830226f8844ac719c6c7e10c7962055df8c4ff667fde3aa595be518f481a7ed1b85e249f8991365df51c6201bc04f2
diff --git a/app-admin/awscli/awscli-1.37.0.ebuild b/app-admin/awscli/awscli-1.37.0.ebuild
new file mode 100644
index 000000000000..4a8e0ae852e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.37.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}