summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-09-16 19:03:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-09-16 19:03:44 +0200
commit5a3ea374b70d902439f2f0691df39b59f1e37c07 (patch)
tree07a09405138fdbd4952c51ebab68749cd6d45129 /app-admin/entr/entr-4.6.ebuild
parentnet-wireless/srslte: bump (diff)
downloadgentoo-5a3ea374b70d902439f2f0691df39b59f1e37c07.tar.gz
gentoo-5a3ea374b70d902439f2f0691df39b59f1e37c07.tar.bz2
gentoo-5a3ea374b70d902439f2f0691df39b59f1e37c07.zip
app-admin/entr: version bump.
Closes: https://bugs.gentoo.org/741724 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/entr/entr-4.6.ebuild')
-rw-r--r--app-admin/entr/entr-4.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/entr/entr-4.6.ebuild b/app-admin/entr/entr-4.6.ebuild
new file mode 100644
index 000000000000..b86dea0ffd94
--- /dev/null
+++ b/app-admin/entr/entr-4.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ default
+}
+
+src_test() {
+ export CC=$(tc-getCC)
+ default
+}