summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-07-26 13:35:43 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2016-07-26 13:35:43 +0200
commitbc23def39c3c70c8ee0eae0f0d9ce77dfb4169d8 (patch)
treeda3b766d27fef5256b3df3cbc69f4fbdf3afd413 /app-admin/logrotate
parentapp-admin/augeas-1.5.0-r0: add alpha keyword (diff)
downloadgentoo-bc23def39c3c70c8ee0eae0f0d9ce77dfb4169d8.tar.gz
gentoo-bc23def39c3c70c8ee0eae0f0d9ce77dfb4169d8.tar.bz2
gentoo-bc23def39c3c70c8ee0eae0f0d9ce77dfb4169d8.zip
app-admin/logrotate: Bump to install binary under /usr/bin
Fixes bug #588156 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-admin/logrotate')
-rw-r--r--app-admin/logrotate/logrotate-3.9.2-r1.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/app-admin/logrotate/logrotate-3.9.2-r1.ebuild b/app-admin/logrotate/logrotate-3.9.2-r1.ebuild
new file mode 100644
index 000000000000..62b75e9e94d1
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.9.2-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://fedorahosted.org/logrotate/"
+SRC_URI="https://github.com/logrotate/logrotate/archive/${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl +cron selinux"
+
+CDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? (
+ sys-libs/libselinux
+ )
+ acl? ( virtual/acl )"
+
+DEPEND="${CDEPEND}
+ >=sys-apps/sed-4"
+
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-logrotate )
+ cron? ( virtual/cron )"
+
+install_cron_file() {
+ exeinto /etc/cron.daily
+ newexe "${S}"/examples/logrotate.cron "${PN}"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ignore-hidden.patch \
+ "${FILESDIR}"/${P}-fbsd.patch \
+ "${FILESDIR}"/${P}-noasprintf.patch \
+ "${FILESDIR}"/${P}-atomic-create.patch \
+ "${FILESDIR}"/${P}-Werror.patch \
+ "${FILESDIR}"/${P}-lfs.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with acl) $(use_with selinux)
+}
+
+src_compile() {
+ emake ${myconf} RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ insinto /usr
+ dobin logrotate
+ doman logrotate.8
+ dodoc CHANGES examples/logrotate*
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ use cron && install_cron_file
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog "The ${PN} binary is now installed under /usr/bin. Please"
+ elog "update your links"
+ elog
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+ fi
+}