summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-02-03 13:39:01 +0100
committerPatrick Lauer <patrick@gentoo.org>2017-02-03 13:39:01 +0100
commit1699451fb954959bb35e8bed6e47680c5efa2b1b (patch)
tree6738372fbbdf5ecf5315b42c33db940bb64e7529 /app-admin/lsyncd/lsyncd-2.2.1.ebuild
parentdev-lang/hy: Bump (diff)
downloadgentoo-1699451fb954959bb35e8bed6e47680c5efa2b1b.tar.gz
gentoo-1699451fb954959bb35e8bed6e47680c5efa2b1b.tar.bz2
gentoo-1699451fb954959bb35e8bed6e47680c5efa2b1b.zip
app-admin/lsyncd: Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/lsyncd/lsyncd-2.2.1.ebuild')
-rw-r--r--app-admin/lsyncd/lsyncd-2.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/lsyncd/lsyncd-2.2.1.ebuild b/app-admin/lsyncd/lsyncd-2.2.1.ebuild
new file mode 100644
index 000000000000..92ad9b8b48be
--- /dev/null
+++ b/app-admin/lsyncd/lsyncd-2.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_IN_SOURCE_BUILD="YES_PLEASE_OMG"
+inherit cmake-utils
+
+DESCRIPTION="Live Syncing (Mirror) Daemon"
+HOMEPAGE="https://github.com/axkibe/lsyncd"
+SRC_URI="https://github.com/axkibe/lsyncd/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+
+CDEPEND=">=dev-lang/lua-5.1[deprecated]"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ net-misc/rsync"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-mandir.patch
+)
+
+S=${WORKDIR}/${PN}-release-${PV}