summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-09-22 15:34:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2024-09-22 15:37:09 -0500
commit943b99fe2e3f4ad46a07240b3a36a55622e32589 (patch)
tree313fb1177774ffcfede8b8365c9e1c6752289e24 /app-admin/puppet-agent
parentapp-admin/puppetdb: add 8.7.0 (diff)
downloadgentoo-943b99fe2e3f4ad46a07240b3a36a55622e32589.tar.gz
gentoo-943b99fe2e3f4ad46a07240b3a36a55622e32589.tar.bz2
gentoo-943b99fe2e3f4ad46a07240b3a36a55622e32589.zip
app-admin/puppet-agent: add 8.9.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-8.9.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index d172a2c2a202..e8ed94665c3c 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -4,3 +4,5 @@ DIST puppet-agent_8.5.1-1focal_amd64.deb 35945834 BLAKE2B 8c839eabf8abbc6cf87ab8
DIST puppet-agent_8.5.1-1focal_arm64.deb 35436770 BLAKE2B 16ead6317dab6f8b65b8ea5269eec5593697f4da6d1ec0323e074f4eab3c8518dab10af48853e591aecc62c63a5ff4e135cf02bb1d7f7d565c5200bfae98ff86 SHA512 f3acc097563d9a56cb677df72250ee25ab0e1e361eb40a2cd36b3d694854edc3850f08099b916aefbc16580f78a194e9f3bf33b1cb585836d55c6e8dcf03a379
DIST puppet-agent_8.6.0-1focal_amd64.deb 35966100 BLAKE2B a27e5fd32c73dd798612cc78a2e4abc150b425215592e9c7a88c7d3b54a2f6dcaffd557575e7c6f64116228fdd50e15a503f8b4c8c496c0f970ee772d5a88e6c SHA512 10a89f73219da6b59e63e8d2aba63968ef2236e773077c54ef6001b010b20b3e384676880cc10b8be4fc16336bb123783de88b0fd1d5c5d91c2455f410458363
DIST puppet-agent_8.6.0-1focal_arm64.deb 35459524 BLAKE2B 5c9bc90eb3b2857176988acb41ebf0eed173077adabe74a6570ada92f9c2c829a57b949ea0c1cb1cae2e7b562b52882da58fab1552934e18bd676163c10e1924 SHA512 f91d82dcb66667891c6155e171739f34a174529a09c376fc7e1a829cd6862e52d26dc39ab3b0d273e32b56e52c62193c8d574d5164f3152bab6e50b4872c5e52
+DIST puppet-agent_8.9.0-1focal_amd64.deb 36339482 BLAKE2B d3ed494da8d576a44c33b6c89840193e802310027f850391bd124186f84badc4f846163792fa6f2d16a1342f0542b907ef987bb716a9d7679460bb0b0dcd0da8 SHA512 8fd343925f280b281209109a75640dd7a8990b937fd1085703da21494194d3dd6ea934ba80cbfb4c5447975822273de94687b4f504e15fb316169b52364bc0ab
+DIST puppet-agent_8.9.0-1focal_arm64.deb 35843072 BLAKE2B e394ed90277299e5c86b0449fe5a49a890d738845b686e1c2d790fc50e4dee351057d63d091ed6d33180a864e5e884ee75cae9d80cb418e792f49953962f0f7f SHA512 4baeb4eac079f80be38ccffe5db2d91f9dc4f6a6bac2423a40f4f105757ecec3831e2f58bd2ba0f355fac79d4c3569766d1931c2ea531bc10bcaef08b8d9dad8
diff --git a/app-admin/puppet-agent/puppet-agent-8.9.0.ebuild b/app-admin/puppet-agent/puppet-agent-8.9.0.ebuild
new file mode 100644
index 000000000000..f5524d744e1b
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-8.9.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="amd64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb )
+arm64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_arm64.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}