summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-12-10 12:48:08 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-12-10 12:49:22 -0600
commitfe85fa192aa979ba7149d4e040134691500bf3ed (patch)
treeebf4eb167fc7866302236988b61e21b273e5f2b0 /app-admin/puppet-agent
parentapp-admin/puppet: add 7.21.0 (diff)
downloadgentoo-fe85fa192aa979ba7149d4e040134691500bf3ed.tar.gz
gentoo-fe85fa192aa979ba7149d4e040134691500bf3ed.tar.bz2
gentoo-fe85fa192aa979ba7149d4e040134691500bf3ed.zip
app-admin/puppet-agent: add 7.21.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.21.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index e7eff448d619..f8dc6d3db9d2 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_7.19.0-1focal_amd64.deb 33779898 BLAKE2B 40ced6309bc82a2a91757
DIST puppet-agent_7.19.0-1focal_arm64.deb 33570768 BLAKE2B 21f7c6c8a42a14156f209313f0dce40336a53fdb097abe620edcb92b2cceaa20e08adec8fc22241886eac3ad0a7ba94d805dc1e2d9bbd37853ff037a49f004fd SHA512 306236a7543f01b3fb95edbe3b442717a64aeb22d696c9961a770e9da40b2bb58835c6d9488b03109b81f8b748106189c361d5f047e9202700e0801486d18206
DIST puppet-agent_7.20.0-1focal_amd64.deb 33766302 BLAKE2B 665f4d4d8c3b096ec5f270428d0b865dc10b77c51113f65f9e66ab6bb72c3b21a07acd9433f2cc1e4e05c0fb30a11884f0bfe7a5a8a9a1d882bdd049a5490b84 SHA512 91b7eef80bc5e288f8a59a52d41340d1bc921e0754151952a3921575787e4cec1f101039c75a01ca6e7e4a5512224922be0c5be7a676d92bb19d3de291a7ab8c
DIST puppet-agent_7.20.0-1focal_arm64.deb 33547934 BLAKE2B 323d76ac12af0c97cf38b8a78454be89c900eebcc9b1517c716700badf8845c062d2c4eb2f633ed1b6ffc36cb42e7e16a3e4e815637e92c209bc6f3c40cfd525 SHA512 a04727c71cf241e352d14bcc09eb340199a7e42b18be574d822a793ff9d91ff1e1879d67724dbf2133a6a3842fa86ed45b048845c73a5669fab45dacea3e616a
+DIST puppet-agent_7.21.0-1focal_amd64.deb 32897404 BLAKE2B 5075c0c77ae2199a3743edcc7fda94802f7b845b37084a613547705a3dc403259908698036bad95e36d7ba18c8b165971d98b81b64e56e6b40f3360e00c4fc5b SHA512 cad621b9add8c7397c681684696b78d57c149b174a43830c3c45ea1679aba791005b634a64b48b3a9d276fb00d7e1ca8e2a73f6a02756d020914f507a35dc56a
+DIST puppet-agent_7.21.0-1focal_arm64.deb 32630670 BLAKE2B 634fed97c79ca3b317ee079366a262c898ef217236014dc683cf1c11e83f2fd74bc21c18ff5242ebd2a4b15b73852ed727976134f684e0d416ac0a3ee54221c3 SHA512 be6a0566db5b1ab72b8f53bdf061c0ad4fb93794d690c6ebe697c9eb5aae45b7838b266619c5c33f3c4499a7264fb083d3f2bbb1fbf70b73458c8aa24470e3c3
diff --git a/app-admin/puppet-agent/puppet-agent-7.21.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.21.0.ebuild
new file mode 100644
index 000000000000..3ef55d1516d2
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-7.21.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="amd64? ( http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb )
+arm64? ( http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_arm64.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}