summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:15:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:18:54 -0500
commit2adfcde3e96960f8a96a19a53fed083b0df6478f (patch)
tree997c07a69840903e14a3520dc21781c5d4b23e12 /app-admin/puppet
parentapp-admin/ansible: add 9.4.0 (diff)
downloadgentoo-2adfcde3e96960f8a96a19a53fed083b0df6478f.tar.gz
gentoo-2adfcde3e96960f8a96a19a53fed083b0df6478f.tar.bz2
gentoo-2adfcde3e96960f8a96a19a53fed083b0df6478f.zip
app-admin/puppet: add 8.6.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-8.6.0.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 28216718f403..aa69cc8b22a8 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -4,3 +4,4 @@ DIST puppet-7.28.0.tar.gz 2827538 BLAKE2B 65f25d9de60ed1b511acb5c9d72370198f68f3
DIST puppet-8.4.0.tar.gz 2882328 BLAKE2B de46a8fbdc7522f022d19953845c73e6872ed430a9380f157809bb95e7d7315063f136b5159468708dcb5dcb4353cc89eacffffbd4045458351c63261a6d9bd0 SHA512 23d5aede9ba55e4e63a7f815fd1d274e97d5d0c35aa1b5444c24b223a59d5d913ac5b4652acc2258b1721a213e4c24e1e8b4a146ca6a1b81a1536a51ed856270
DIST puppet-8.5.0.tar.gz 1565122 BLAKE2B c787b981c64f2b52cc3c8998516599891980bb176cb3bce6596cb4b139fbae2f58e156fb007a3aa2bd2a5bb069dc63eb7fc36bde3f3533c27729fccfa19ee0e7 SHA512 1adf88f69b3b5a7071a2ee5dad66c3cd3fc1db57fdeaf7945f8cb167d1b76dcf12e85e17eefc418cda67952a4c75a6b43d320d0c0f1db610411d188304994cdc
DIST puppet-8.5.1.tar.gz 1565085 BLAKE2B f352f9f70e090c4a32edd45ced5c01ed4eff891fb46c0f2d753ceeba43250960356ceb2d9047e7308732585ec114c5f728ec29a65b6a08348b74a9709ec92a89 SHA512 f1d661c34fc7c1381c6422ff7e027fdf4554a69939f5db926bf8a61a89583090fb8d28151f90093d3ca8037950ed911b0a5c7b8677a80ede72e83d9cbf89af7f
+DIST puppet-8.6.0.tar.gz 1567398 BLAKE2B 749cc055c6797e5715907fdb768264774efba62e4681733a59a457cfda9dd2682990a96331cc04d313a367e32b820ce351fb103e19891976e900d99c30ca7ba5 SHA512 b08d59b4ec79fec5f3dd2d37c9b6a9f016cf25068e507866ab8d545f59792b9af84e302675182a0318c792814f0bff2bf052c8953b6b44c5441fa2c692a9f04d
diff --git a/app-admin/puppet/puppet-8.6.0.ebuild b/app-admin/puppet/puppet-8.6.0.ebuild
new file mode 100644
index 000000000000..6ee8a0e304c8
--- /dev/null
+++ b/app-admin/puppet/puppet-8.6.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_RUBY="ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit ruby-fakegem systemd tmpfiles
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv x86"
+IUSE="augeas diff doc emacs hiera ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ hiera? ( dev-ruby/hiera )
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ dev-ruby/deep_merge
+ dev-ruby/concurrent-ruby
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # fix systemd path
+ eapply -p0 "${FILESDIR}/puppet-systemd.patch"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" \
+# "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ newtmpfiles "${FILESDIR}/tmpfiles.d-2" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"
+ dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet.conf
+
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+}