summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/pydf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/pydf')
-rw-r--r--app-admin/pydf/Manifest2
-rw-r--r--app-admin/pydf/metadata.xml8
-rw-r--r--app-admin/pydf/pydf-10-r1.ebuild32
-rw-r--r--app-admin/pydf/pydf-12.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/app-admin/pydf/Manifest b/app-admin/pydf/Manifest
new file mode 100644
index 000000000000..2ef9685d6f49
--- /dev/null
+++ b/app-admin/pydf/Manifest
@@ -0,0 +1,2 @@
+DIST pydf_10.tar.gz 13430 SHA256 71be682c86a352afbafcf612cbc236f6f5810d80635685869a9c9b320203e241 SHA512 d8bf8a0a6e70fc02c5ff97844c224cc49036cc27bd01c50330dd3aa898e036d995952c8f83b84c3ccaa28753504fa1ef664f354190ffc127e67ea413ae90906b WHIRLPOOL 2bc7a137c600bf080052716b6a3e59546a2e79308810540472047471481d6a4174d8093b3ad15df8fe9d36d3c28b5c59ef48355bf7d74db8b2e00b27fa745677
+DIST pydf_12.tar.gz 14207 SHA256 860029145e42f3484fa647c42966c236d90cba0221681dbf5f48257b6c5b8c92 SHA512 5a5819b83fe2425cb951a139b38b1b639d17e1d17c4e3e4a80fc4eb6d5632c42b03a2767e1864c8bee13dbd72ebb91ec79fefde1ba448e2af9fc4a314821a3d0 WHIRLPOOL 0e5ac13af4ed1ecf8aa4b6c203fc7309032692c2b4dc1e029a4c8897d7430be58bf3ef7cea549e2432142586dc76b42fcb790a90cc9b61fe68ee860d720200b9
diff --git a/app-admin/pydf/metadata.xml b/app-admin/pydf/metadata.xml
new file mode 100644
index 000000000000..f2b4a5d1d932
--- /dev/null
+++ b/app-admin/pydf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/pydf/pydf-10-r1.ebuild b/app-admin/pydf/pydf-10-r1.ebuild
new file mode 100644
index 000000000000..f63627c1acad
--- /dev/null
+++ b/app-admin/pydf/pydf-10-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit python-r1
+
+DESCRIPTION="Enhanced df with colors"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/"
+SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s:/etc/pydfrc:${EPREFIX}/etc/pydfrc:" pydf || die
+}
+
+src_install() {
+ python_foreach_impl python_doscript pydf
+ insinto /etc
+ doins pydfrc
+ doman pydf.1
+ dodoc README
+}
diff --git a/app-admin/pydf/pydf-12.ebuild b/app-admin/pydf/pydf-12.ebuild
new file mode 100644
index 000000000000..da5e2e67c921
--- /dev/null
+++ b/app-admin/pydf/pydf-12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit python-r1
+
+DESCRIPTION="Enhanced df with colors"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/"
+SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s:/etc/pydfrc:${EPREFIX}/etc/pydfrc:" pydf || die
+}
+
+src_install() {
+ python_foreach_impl python_doscript pydf
+ insinto /etc
+ doins pydfrc
+ doman pydf.1
+ dodoc README
+}