summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-13 20:47:10 +0000
committerSam James <sam@gentoo.org>2021-04-13 22:37:39 +0000
commit28e5e044aa65c4e3c1748716e7f0224fbfd94676 (patch)
treea1f75706cbbdac2da88e32ea3725611bc2301c10 /app-admin/syslog-ng/files
parentmail-mta/esmtp: use PKG_CHECK_MODULES for libesmtp (diff)
downloadgentoo-28e5e044aa65c4e3c1748716e7f0224fbfd94676.tar.gz
gentoo-28e5e044aa65c4e3c1748716e7f0224fbfd94676.tar.bz2
gentoo-28e5e044aa65c4e3c1748716e7f0224fbfd94676.zip
app-admin/syslog-ng: use pkgconfig to find libesmtp
The newer version of libesmtp (snapshot) drops autotools and dropped its homebrew libesmtp-config utility too. We now have to use pkgconfig to find it. Bug: https://bugs.gentoo.org/782643 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/syslog-ng/files')
-rw-r--r--app-admin/syslog-ng/files/syslog-ng-3.30.1-esmtp-pkgconfig.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/syslog-ng/files/syslog-ng-3.30.1-esmtp-pkgconfig.patch b/app-admin/syslog-ng/files/syslog-ng-3.30.1-esmtp-pkgconfig.patch
new file mode 100644
index 000000000000..ef4f72faa319
--- /dev/null
+++ b/app-admin/syslog-ng/files/syslog-ng-3.30.1-esmtp-pkgconfig.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/782643
+--- a/configure.ac
++++ b/configure.ac
+@@ -1270,20 +1270,9 @@ if test "x$enable_smtp" != "xno" && test "x$with_libesmtp" != "xno"; then
+ CPPFLAGS="$CPPFLAGS_SAVE"
+ LDFLAGS="$LDFLAGS_SAVE"
+ else
+- AC_MSG_CHECKING(for libESMTP)
+- if libesmtp-config --version >/dev/null 2>&1; then
+- AC_MSG_RESULT(yes)
+- LIBESMTP_CFLAGS="`libesmtp-config --cflags`"
+- LIBESMTP_LIBS="`libesmtp-config --libs`"
+- else
+- AC_MSG_RESULT(no)
+- libesmtp=no
+- fi
+- fi
+- if test "x$enable_smtp" = "xyes" && test "x$libesmtp" = "xno"; then
+- AC_MSG_ERROR(libESMTP not found)
++ PKG_CHECK_MODULES(libesmtp, libesmtp-1.0)
+ fi
+- enable_smtp=$libesmtp
++ enable_smtp="yes"
+ fi
+
+ dnl ***************************************************************************