summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/system-tools-backends
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/system-tools-backends')
-rw-r--r--app-admin/system-tools-backends/Manifest1
-rw-r--r--app-admin/system-tools-backends/files/stb.rc21
-rw-r--r--app-admin/system-tools-backends/files/system-tools-backends-2.8.2-cve-2008-4311.patch47
-rw-r--r--app-admin/system-tools-backends/files/system-tools-backends-2.8.2-default-permissions.patch25
-rw-r--r--app-admin/system-tools-backends/metadata.xml10
-rw-r--r--app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild67
6 files changed, 171 insertions, 0 deletions
diff --git a/app-admin/system-tools-backends/Manifest b/app-admin/system-tools-backends/Manifest
new file mode 100644
index 000000000000..13d48716b611
--- /dev/null
+++ b/app-admin/system-tools-backends/Manifest
@@ -0,0 +1 @@
+DIST system-tools-backends-2.10.2.tar.bz2 448939 SHA256 1dbe5177df46a9c7250735e05e77129fe7ec04840771accfa87690111ca2c670 SHA512 9ee3e0643122740493265e532350fed9056334de0ea3d6656daa1d42b97f76f0f85024ac87e732fe5122a1e31ad009a1d2f119720081673a06696b81452fb990 WHIRLPOOL 2357ca2249b8f7c7ce3fc7ffcb4c49bcd83040d77910bbb1ce19e47750da999e6d359689d14c284a84b421287d5a8d3d183fc1debd0b119aa520dd125ca1a599
diff --git a/app-admin/system-tools-backends/files/stb.rc b/app-admin/system-tools-backends/files/stb.rc
new file mode 100644
index 000000000000..45e8b85b8d93
--- /dev/null
+++ b/app-admin/system-tools-backends/files/stb.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need dbus
+}
+
+start() {
+ ebegin "Starting system-tools-backend"
+ start-stop-daemon --start --exec /usr/sbin/system-tools-backends -- -D
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping system-tools-backend"
+ start-stop-daemon --stop --pidfile /var/run/system-tools-backends.pid
+ eend $?
+}
+
diff --git a/app-admin/system-tools-backends/files/system-tools-backends-2.8.2-cve-2008-4311.patch b/app-admin/system-tools-backends/files/system-tools-backends-2.8.2-cve-2008-4311.patch
new file mode 100644
index 000000000000..47f93da74f16
--- /dev/null
+++ b/app-admin/system-tools-backends/files/system-tools-backends-2.8.2-cve-2008-4311.patch
@@ -0,0 +1,47 @@
+From 544d679c2796602ff277e78e238abd56d30ad633 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 14 Dec 2009 20:37:58 +0100
+Subject: [PATCH 3/4] Gentoo: fix CVE-2008-4311
+
+commit fd648907e46017d46c367f59c62d0b0395830903
+Author: Simon McVittie <http://smcv.pseudorandom.co.uk/>
+Date: 2009-01-04 19:35:51 +0000
+
+ Allow root to send messages to all the system tools backends, so
+ they work even when CVE-2008-4311 has been fixed.
+
+ Also disallow normal user access by destination, not by
+ interface (fd.o #18961).
+---
+ org.freedesktop.SystemToolsBackends.conf | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/org.freedesktop.SystemToolsBackends.conf b/org.freedesktop.SystemToolsBackends.conf
+index 58972ee..537ef73 100644
+--- a/org.freedesktop.SystemToolsBackends.conf
++++ b/org.freedesktop.SystemToolsBackends.conf
+@@ -22,8 +22,10 @@
+ <allow send_interface="org.freedesktop.SystemToolsBackends.Platform" send_member="getPlatform"/>
+ -->
+
+- <!-- Only allow talking to the dispatcher -->
+- <allow send_destination="org.freedesktop.SystemToolsBackends"/>
++ <!-- configuration modules can't be accessed directly... -->
++ <deny send_destination="org.freedesktop.SystemToolsBackends"/>
++ <deny send_destination="org.freedesktop.SystemToolsBackends.Platform"/>
++ <deny send_destination="org.freedesktop.SystemToolsBackends"/>
+ </policy>
+
+ <policy user="0">
+@@ -45,8 +47,6 @@
+
+ <!-- be able to speak to configuration modules,
+ so any message to them has to go through the dispatcher -->
+- <allow send_interface="org.freedesktop.SystemToolsBackends"/>
+- <allow send_interface="org.freedesktop.SystemToolsBackends.Platform"/>
+ <allow send_destination="org.freedesktop.SystemToolsBackends"/>
+ <allow send_destination="org.freedesktop.SystemToolsBackends.Platform"/>
+ <allow send_destination="org.freedesktop.SystemToolsBackends.GroupsConfig"/>
+--
+1.6.5.4
+
diff --git a/app-admin/system-tools-backends/files/system-tools-backends-2.8.2-default-permissions.patch b/app-admin/system-tools-backends/files/system-tools-backends-2.8.2-default-permissions.patch
new file mode 100644
index 000000000000..bc58ba4fb1f9
--- /dev/null
+++ b/app-admin/system-tools-backends/files/system-tools-backends-2.8.2-default-permissions.patch
@@ -0,0 +1,25 @@
+From ea88120dac8ba2c2dabf4c393c283f69b3d33b5a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 14 Dec 2009 20:37:15 +0100
+Subject: [PATCH 2/4] Gentoo: restrict access to stb to users in stb-admin group
+
+---
+ org.freedesktop.SystemToolsBackends.conf | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/org.freedesktop.SystemToolsBackends.conf b/org.freedesktop.SystemToolsBackends.conf
+index d031525..58972ee 100644
+--- a/org.freedesktop.SystemToolsBackends.conf
++++ b/org.freedesktop.SystemToolsBackends.conf
+@@ -60,4 +60,8 @@
+ <allow send_destination="org.freedesktop.SystemToolsBackends.UserConfig"/>
+ <allow send_destination="org.freedesktop.SystemToolsBackends.UsersConfig"/>
+ </policy>
++ <policy group="stb-admin">
++ <!-- be able to speak to the dispatcher -->
++ <allow send_destination="org.freedesktop.SystemToolsBackends"/>
++ </policy>
+ </busconfig>
+--
+1.6.5.4
+
diff --git a/app-admin/system-tools-backends/metadata.xml b/app-admin/system-tools-backends/metadata.xml
new file mode 100644
index 000000000000..013e6579a275
--- /dev/null
+++ b/app-admin/system-tools-backends/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<longdescription lang="en">
+The System Tools Backends are a set of cross-platform modules for Linux,
+FreeBSD, Solaris and other Unix systems. The backends provide an common DBus
+interface to all distros for modifying or reading the system configuration.
+</longdescription>
+</pkgmetadata>
diff --git a/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild b/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild
new file mode 100644
index 000000000000..b47f4048c6ba
--- /dev/null
+++ b/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2 readme.gentoo user
+
+DESCRIPTION="Tools aimed to make easy the administration of UNIX systems"
+HOMEPAGE="http://projects.gnome.org/gst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 ia64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ !<app-admin/gnome-system-tools-1.1.91
+ >=sys-apps/dbus-1.1.2
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.15.2:2
+ >=dev-perl/Net-DBus-0.33.4
+ dev-lang/perl
+ >=sys-auth/polkit-0.94
+ userland_GNU? ( virtual/shadow )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need to add yourself to the group stb-admin and
+add system-tools-backends to the default runlevel.
+You can do this as root like so:
+# rc-update add system-tools-backends default
+"
+
+pkg_setup() {
+ enewgroup stb-admin
+}
+
+src_prepare() {
+ # Change default permission, only people in stb-admin is allowed
+ # to speak to the dispatcher.
+ epatch "${FILESDIR}/${PN}-2.8.2-default-permissions.patch"
+
+ # Apply fix from ubuntu for CVE 2008 4311
+ epatch "${FILESDIR}/${PN}-2.8.2-cve-2008-4311.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --localstatedir=/var
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}