summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:12:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:18:52 -0500
commit479195ed05b83ea0c39dc67c9847bdbf1edb5382 (patch)
treedc2eb3c42b79579f248514415ed099217e05c9e7 /app-admin
parentkde-frameworks/solid: add 6.1.1, drop 6.1.0 (diff)
downloadgentoo-479195ed05b83ea0c39dc67c9847bdbf1edb5382.tar.gz
gentoo-479195ed05b83ea0c39dc67c9847bdbf1edb5382.tar.bz2
gentoo-479195ed05b83ea0c39dc67c9847bdbf1edb5382.zip
app-admin/ansible-core: add 2.16.6
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-core/Manifest1
-rw-r--r--app-admin/ansible-core/ansible-core-2.16.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/ansible-core/Manifest b/app-admin/ansible-core/Manifest
index c721a898bd3f..0e97f0c84c5e 100644
--- a/app-admin/ansible-core/Manifest
+++ b/app-admin/ansible-core/Manifest
@@ -3,3 +3,4 @@ DIST ansible-core-2.15.8.tar.gz 3160606 BLAKE2B 439a3f584940e5ab46b43b0b47395e06
DIST ansible-core-2.16.2.tar.gz 3163899 BLAKE2B 6365dd573ae4a2f3ebfc870ae3ea399b268615333de2ddf7e21323189dfdd9bf61ae836b536c86d713f4a934468ed36835084e06e4b6d9b32c4b633f55353ad9 SHA512 6e2389fc6b34645c0f1566eca960da36616619a5ed5e35b46f3d659979fe519db20d89b4f598344a389f4b6ac33bb660ea91a1a6509002bbf4ac791ea3cb4cbd
DIST ansible-core-2.16.4.tar.gz 3170397 BLAKE2B 8226641621ce4b2a8cd564f831cd21e36345b2db6680f8d9f3d3388a05ff66df74f4d286300dbb1b73601a0bf4a781d266e62e9fd0c894a79f89d545930c854a SHA512 d05737eec9a6a0e71891821acd4540576b3a993f59d88c12c2da8e7f075bc11c712e0eba850b3f7a2643e3c970f51938267fed6fa7f99f2c4c205b64f9b13259
DIST ansible-core-2.16.5.tar.gz 3171617 BLAKE2B cb620cf9fc9fd509edb62bf75ab19b5ffe80f4d8520be76bbeb030c74953945295e0f4f30102f51d20247d2ce4a18b15e488e47b4346319f5442979593402821 SHA512 dbe5d68fbc3a0ef611791d6995297bca5bba6aed1f4871964136ea81810458646bc78c2146739f887de3c2e3017cf4e6d4d09652e41c2ca046c4bc88eca6c5d8
+DIST ansible_core-2.16.6.tar.gz 3176041 BLAKE2B 37aa15e8d9165eb89db0704f7670f78f3e3a50915e17bb1d56689e65e6cfc0bb15b7e01768d25c5d2a9a00802411a6eefdb9ad70aa38877d7115bc40faafea59 SHA512 cd9cc8783e13b073cbfaef889e20c8a7dfb732c91de4bae2b496a64ef47b0325c637b4ab2eadbd0c56cb004e95f5294aa1e1548675a90f06193d62defd553409
diff --git a/app-admin/ansible-core/ansible-core-2.16.6.ebuild b/app-admin/ansible-core/ansible-core-2.16.6.ebuild
new file mode 100644
index 000000000000..45a1511c7489
--- /dev/null
+++ b/app-admin/ansible-core/ansible-core-2.16.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-1.1.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+BDEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}