summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-03-31 23:24:24 -0700
committerZac Medico <zmedico@gentoo.org>2024-03-31 23:24:44 -0700
commit66cdfe8862bca8783aea8c83e0c301db1afa2333 (patch)
treeb246544857d3eb07f2bab551aabe22e7aa2b4993 /app-admin
parentapp-admin/consul: add 1.15.11 (diff)
downloadgentoo-66cdfe8862bca8783aea8c83e0c301db1afa2333.tar.gz
gentoo-66cdfe8862bca8783aea8c83e0c301db1afa2333.tar.bz2
gentoo-66cdfe8862bca8783aea8c83e0c301db1afa2333.zip
app-admin/consul: drop 1.15.7
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul/Manifest1
-rw-r--r--app-admin/consul/consul-1.15.7.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 02c61d0bc02a..71cc8fa00c88 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -2,4 +2,3 @@ DIST consul-1.15.10-vendor.tar.gz 46702348 BLAKE2B a04d6f5a4d2f6f8885207f9f72537
DIST consul-1.15.11-deps.tar.xz 9566892 BLAKE2B 9459a93d78d3e4b991d0cdcfac22603c628c8f9fdacd8d50524a4c826cca66a575f6cd0bdf5fa9033e32b50336c53192567610ed73386f89c3c4e810c1412144 SHA512 d3876433b4ad3e7a062e059ef250bcfba23ede0595d8491f4b39c73c427e28c677b9f6e41317cf853ab8b3b2ce25151a4adf1a13b13a6a73c6e16de7382d2d05
DIST consul-1.15.11.tar.gz 28951114 BLAKE2B 02378088d1bbc4313ec62d644b583c328bc9cc40ccc18516a1a14ae0d7f8d12007f1a5fa7c5e455ec2e782ba986ce60d37b92369b1f89f7dd69871702cd97b31 SHA512 1c5c8f9a3ad79aa34fd82a49e92ef5a21fb0470d60e3f3413901305121cbb677c75f72ffd5405554424b336d4e5ec426b7c35f458c04b1d5ab9350c2649cd688
DIST consul-1.15.3-vendor.tar.gz 43434721 BLAKE2B 7595c98cdecf67e9fb412d8fea1d790dc6b1c29f7bc427e1d0872045a05f8873dc6107f196cea04fe0a2f2553d4fbb1f8d501e5e107b2bea3ae841e5d94eda64 SHA512 b69e3a7c1ebb01c7a64f2c6167e63e8a530b81be9aad8b591d0a71f512f5157ba9a564b46f9effe52a5abd3ae61732e7af10c5ba002110f745eb3d94ebcec256
-DIST consul-1.15.7-vendor.tar.gz 46252048 BLAKE2B c63d69fb206895c535ffd60ada3589d99ec6aec81d7abe6b27169d4638bcc272f5d7c0b37d0bbe6be54f5e2d32f1e40fa1f4088da7fb4931f0c5c10007838197 SHA512 1e52f133f822cf11ee8498b7e92a7460c74d3ed4736c02e0957e3d950608f4aeaec8e8df7e9eb72ae7d4c31c4dcf5d827c9c42bdc7c4b991be53df22c150658a
diff --git a/app-admin/consul/consul-1.15.7.ebuild b/app-admin/consul/consul-1.15.7.ebuild
deleted file mode 100644
index 2b693c361655..000000000000
--- a/app-admin/consul/consul-1.15.7.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd
-
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-GIT_COMMIT="8e803db6b98d10b2d310800f2aef7e20d3add03c"
-
-SRC_URI="https://github.com/zmedico/consul/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
-
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-RESTRICT="test"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-BDEPEND="dev-go/gox"
-COMMON_DEPEND="
- acct-group/consul
- acct-user/consul"
- DEPEND="${COMMON_DEPEND}"
- RDEPEND="${COMMON_DEPEND}"
-
-S=${WORKDIR}/${P}-vendor
-
-src_prepare() {
- default
- sed -e 's|^GIT_DATE=.*|GIT_DATE=2023-10-31T14:10:44Z|' -i GNUmakefile || die
-}
-
-src_compile() {
- if use x86; then
- #924629 pie breaks build on x86
- GOFLAGS=${GOFLAGS//-buildmode=pie}
- fi
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${GIT_COMMIT}" \
- emake dev-build
-}
-
-src_install() {
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- keepdir /var/log/consul
- fowners consul:consul /var/log/consul
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}