summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 06:08:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 06:27:45 +0200
commit6a2b0d71e8cf0d4b95e7c81f3b5cae235cab30cd (patch)
treeca50083178394af541cdbc4a286c1f729dfa1e00 /app-admin
parentdev-python/boto3: Bump to 1.21.35 (diff)
downloadgentoo-6a2b0d71e8cf0d4b95e7c81f3b5cae235cab30cd.tar.gz
gentoo-6a2b0d71e8cf0d4b95e7c81f3b5cae235cab30cd.tar.bz2
gentoo-6a2b0d71e8cf0d4b95e7c81f3b5cae235cab30cd.zip
app-admin/awscli: Bump to 1.22.90
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.90.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 7d6dcbe8f18a..08ec5111089e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -11,3 +11,4 @@ DIST awscli-1.22.86.tar.gz 2184477 BLAKE2B fee34978cef17a0b4f51a9a110836882e1164
DIST awscli-1.22.87.tar.gz 2185493 BLAKE2B 5d274e0c9483b22e664ad6de8710c04cc99f854b7c1efdac6dd4164deab47dc55d35520b34b276f8b4de1ee8b1ed10205b1806a31fc776d17b289a5e29277016 SHA512 c117fb8f89680836206f678637fb480ffd06db2225533bff75686eb8c1bd6e450297adb11863247441eeed67744b13930c0f62afce1dd12527d06d4e2eb58a4b
DIST awscli-1.22.88.tar.gz 2185767 BLAKE2B cf7d161ae781f9a66053a0b0b65c9fdfe9048c924c46b3052ac6c1156bfaa67adba46f36dfa5a7b12686106af1c928450acc10fe03e9c442286a9a5662d992db SHA512 d5d8fcf05322413ba817f9d5f86d8c7e3863d769f9e9ec298ebb686729273ca82a90bf78eb09ac15ba65bc0b68435394d141210ffdcf55bbe7468a62b49a4113
DIST awscli-1.22.89.tar.gz 2186269 BLAKE2B 8b3019cfc585f53145bdbd4342182747cb34dfb3ec75c3cdf7f01e6d4482ac115cdbcf9f077c07fbe0e7e3b312824b6c635165cfafd6b5e19d87b51350e6fcc7 SHA512 90580cdb7a82a14af5d0abc4b67f6ca3e1cd4a2ab68240e54d23a83b52af512b3452498c3baf2e54f9c24dc1243be66cf3f418dcfa4712e312f6bb41624478ad
+DIST awscli-1.22.90.tar.gz 2186538 BLAKE2B 16b1942ee9fa65240a1b8b045b8e3e8659cc299a4cf52a876dae5cdc28088e7d6380c7961934fec590481aab5e71f60d08b21aac620a4485aa5872402c696549 SHA512 ef45718ebc2460e431f5177919a9d2e3de12dd68c9043b27f83ffb589672594fe7116ceed3b5e2fd62d502557a965cd0a3baf4af4de58c4a3176e39ba96e7076
diff --git a/app-admin/awscli/awscli-1.22.90.ebuild b/app-admin/awscli/awscli-1.22.90.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.90.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}