summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-04-01 10:00:09 -0500
committerBen Kohler <bkohler@gentoo.org>2024-04-01 10:02:05 -0500
commit6fdb1222ddc4c142a7d9d459dfe56a701154e410 (patch)
tree8ab5b6f129c59d791f29e05773862b27f3ff1b15 /app-admin
parentdev-python/alembic: Backport pytest-8 fix (diff)
downloadgentoo-6fdb1222ddc4c142a7d9d459dfe56a701154e410.tar.gz
gentoo-6fdb1222ddc4c142a7d9d459dfe56a701154e410.tar.bz2
gentoo-6fdb1222ddc4c142a7d9d459dfe56a701154e410.zip
app-admin/xkcdpass: add 1.19.9
Upstream Changelog: - **1.19.9** Remove usage of deprecated `assertEquals` in tests Closes: https://bugs.gentoo.org/928155 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/xkcdpass/Manifest1
-rw-r--r--app-admin/xkcdpass/xkcdpass-1.19.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/xkcdpass/Manifest b/app-admin/xkcdpass/Manifest
index 469e593c4df0..b6b56c6115d9 100644
--- a/app-admin/xkcdpass/Manifest
+++ b/app-admin/xkcdpass/Manifest
@@ -1 +1,2 @@
DIST xkcdpass-1.19.8.tar.gz 2689908 BLAKE2B 68d0e6b2799773433962ee19ede47f5983839f4e4cecd4939205c2f0872228b4da5a107176d3931fc41aa47be8e51b7fb7383c1da1898684484be98913c088f9 SHA512 f218a9afdf103444558233f9fe32655d2c604f3553d2782a923f73baa4d69495871557a753a5f38be4607bd373df43cf425c0cc6675b0b1b34723098fdeff7b5
+DIST xkcdpass-1.19.9.tar.gz 2689919 BLAKE2B 089997c82569afa40fd2f7d2046b0dd284491d080597513f963c4e6af49ad20c4e01397af0f1dc3b91a23b95666b492eaaf85c3ac1c8f87d3250e012fd00bdc1 SHA512 b326160e181f0e0485514f10efa6cd8e98e139a8a89af37bad511713a7f46750f6da3ff1eeab20b850e0b5c607d0e329966d100d6bd4fe43b80d3edce090a2c1
diff --git a/app-admin/xkcdpass/xkcdpass-1.19.9.ebuild b/app-admin/xkcdpass/xkcdpass-1.19.9.ebuild
new file mode 100644
index 000000000000..206d383064ae
--- /dev/null
+++ b/app-admin/xkcdpass/xkcdpass-1.19.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Password generator inspired by XKCD 936"
+HOMEPAGE="https://github.com/redacted/XKCD-password-generator"
+
+LICENSE="BSD CC-BY-3.0
+ l10n_de? ( GPL-3 )
+ l10n_it? ( CC-BY-SA-3.0 )
+ l10n_no? ( CC-BY-4.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_de +l10n_en l10n_es l10n_fi l10n_fr l10n_it l10n_no l10n_pt"
+
+distutils_enable_tests pytest
+REQUIRED_USE="test? ( l10n_en )"
+
+src_prepare() {
+ default
+
+ use l10n_de || rm ${PN}/static/{ger-anlx,eff_large_de_sample.wordlist}
+ use l10n_en || rm ${PN}/static/{eff-short,eff-special,legacy}
+ use l10n_es || rm ${PN}/static/spa-mich
+ use l10n_fi || rm ${PN}/static/fin-kotus
+ use l10n_fr || rm ${PN}/static/fr-*
+ use l10n_it || rm ${PN}/static/ita-wiki
+ use l10n_no || rm ${PN}/static/nor-nb
+ use l10n_pt || rm ${PN}/static/pt-*
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}