summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-24 10:00:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-24 10:20:22 +0200
commit7d0cb63ba19a6c89e292499ced0758eb12abcf56 (patch)
treecc5f3bfdfbed215938f4670f707ca309929658cc /app-admin
parentdev-python/boto3: Bump to 1.17.99 (diff)
downloadgentoo-7d0cb63ba19a6c89e292499ced0758eb12abcf56.tar.gz
gentoo-7d0cb63ba19a6c89e292499ced0758eb12abcf56.tar.bz2
gentoo-7d0cb63ba19a6c89e292499ced0758eb12abcf56.zip
app-admin/awscli: Bump to 1.19.99
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.19.99.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 89c5727c75c4..8307e4a39da6 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -19,3 +19,4 @@ DIST awscli-1.19.95.tar.gz 2019311 BLAKE2B 4ab4901cbc701e5697f5a98e61df401cdcde0
DIST awscli-1.19.96.tar.gz 2019687 BLAKE2B 77ea6eba698a0ea95261741b68416091fe33a1268c5c3d8d52d286e652929e597767ce5a6d5f8012ad0911a8fd7f86b33dadfc4ab1a5087a5a36c8e7e1f41217 SHA512 ba22fd866dc4ce7fe927e2a63fea784514057cc5b3e5259c5d6b73c42d10f68bba9732c4373e6eb4145aedfe6c373e6c5764a2c5ca31ba935cdaba6b31eeeb00
DIST awscli-1.19.97.tar.gz 2020143 BLAKE2B 2dac6f59a04a958b09e0f8b7d056583015762df78ed1349b55c6301d3189e1100bd8ab98445ded3ccc0ddbf1148ddf0475086704f123b0db1ccfd1cacb6b4680 SHA512 4e4e0f34ba02819232427f7571a4b10d22b167788d758c9ac43749607ea7a4c498259fcc5c69fb32d66faffc535a5b3045006168b64506f2b0f9fbbaa804e387
DIST awscli-1.19.98.tar.gz 2020264 BLAKE2B 4a466af94d909ff072ac54631769345fbdcc167012cbef64fc315a2ab9acf0516cad5f684123ffccc64c16e48791bd469f3c30e76317963bbf4ddbdb806934aa SHA512 74e52fd242fd606bff2913fffb3e5a84abea88bf487f110d0b7144cfffd1ccf18c96103bcf88ed94a101689e11b22bf2d1a77cebe09083839ed1f0f8abd00fd1
+DIST awscli-1.19.99.tar.gz 2021763 BLAKE2B b3c78764c91f6a333ad493aa14d4af54e34e4e6658469d345e16e3cf05ed7ac6c80322ce55ad8831ffff369e1dcec3125b1422b2888176b47b4b4b9544a124fd SHA512 281bf1a2fd0868519589749923e3040551cd8d6d9831b20558f492633a2d0734d4fe570e85c1b8ab6230d33fecc851d5b88f69dc5173b08dcd240952737e9003
diff --git a/app-admin/awscli/awscli-1.19.99.ebuild b/app-admin/awscli/awscli-1.19.99.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.19.99.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}