summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Scharrer <daniel@constexpr.org>2016-03-10 16:46:55 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-03-10 22:56:03 +0000
commit63d58d65a60eb97413d606875549f46c9e3a3a74 (patch)
tree890127cd431cac6abc02733450ceff17b8601a59 /app-arch/innoextract/innoextract-1.5.ebuild
parentdev-ruby/dep_selector: Remove ruby19 (diff)
downloadgentoo-63d58d65a60eb97413d606875549f46c9e3a3a74.tar.gz
gentoo-63d58d65a60eb97413d606875549f46c9e3a3a74.tar.bz2
gentoo-63d58d65a60eb97413d606875549f46c9e3a3a74.zip
app-arch/innoextract: fix build with cmake 3.5
Closes: https://github.com/gentoo/gentoo/pull/1025 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-arch/innoextract/innoextract-1.5.ebuild')
-rw-r--r--app-arch/innoextract/innoextract-1.5.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-arch/innoextract/innoextract-1.5.ebuild b/app-arch/innoextract/innoextract-1.5.ebuild
index de642008c533..eedb4ed6dcbb 100644
--- a/app-arch/innoextract/innoextract-1.5.ebuild
+++ b/app-arch/innoextract/innoextract-1.5.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit cmake-utils
+inherit eutils cmake-utils
DESCRIPTION="A tool to unpack installers created by Inno Setup"
HOMEPAGE="http://constexpr.org/innoextract/"
@@ -23,6 +23,11 @@ DEPEND="${RDEPEND}"
DOCS=( README.md CHANGELOG )
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-cmake-3.5.patch
+ cmake-utils_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_use lzma LZMA)