summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2021-12-19 11:57:01 +0000
committerSam James <sam@gentoo.org>2021-12-19 11:58:36 +0000
commit7ae8e60c449ec6641fc2123c3f3fc56f41bf3e9c (patch)
tree376443573613b3d38338c303d74ce2fac8366b9d /app-arch/lrzip
parentwww-client/firefox: lift pipewire subslot restriction on ESR (diff)
downloadgentoo-7ae8e60c449ec6641fc2123c3f3fc56f41bf3e9c.tar.gz
gentoo-7ae8e60c449ec6641fc2123c3f3fc56f41bf3e9c.tar.bz2
gentoo-7ae8e60c449ec6641fc2123c3f3fc56f41bf3e9c.zip
app-arch/lrzip: fix build on arm64
Closes: https://bugs.gentoo.org/829003 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/lrzip')
-rw-r--r--app-arch/lrzip/lrzip-0.641-r1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-arch/lrzip/lrzip-0.641-r1.ebuild b/app-arch/lrzip/lrzip-0.641-r1.ebuild
index 6c8ec1c9d02f..2a3a5eea7ce8 100644
--- a/app-arch/lrzip/lrzip-0.641-r1.ebuild
+++ b/app-arch/lrzip/lrzip-0.641-r1.ebuild
@@ -20,9 +20,10 @@ RDEPEND="
app-arch/lz4
sys-libs/zlib
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-perl/Pod-Parser
+ amd64? ( dev-lang/nasm )
x86? ( dev-lang/nasm )
"
@@ -38,7 +39,15 @@ src_prepare() {
}
src_configure() {
- econf $(use_enable static-libs static)
+ # ASM optimizations are only available on amd64 and x86, bug #829003
+ local asm=no
+ if use amd64 || use x86; then
+ asm=no
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ --enable-asm=${asm}
}
src_install() {