summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-10 14:52:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-10 14:52:05 +0200
commitbd32feee80dc4d12fd98f2e018d994eb02369da2 (patch)
tree0cb3865a9940e3fc9dc991678070affbba58640f /app-arch/stormlib
parentpackage.mask: Last rite dev-python/rapidfuzz-capi (diff)
downloadgentoo-bd32feee80dc4d12fd98f2e018d994eb02369da2.tar.gz
gentoo-bd32feee80dc4d12fd98f2e018d994eb02369da2.tar.bz2
gentoo-bd32feee80dc4d12fd98f2e018d994eb02369da2.zip
app-arch/stormlib: Bump to 9.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/stormlib')
-rw-r--r--app-arch/stormlib/Manifest1
-rw-r--r--app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch58
-rw-r--r--app-arch/stormlib/stormlib-9.26.ebuild45
3 files changed, 104 insertions, 0 deletions
diff --git a/app-arch/stormlib/Manifest b/app-arch/stormlib/Manifest
index 277ba0aa2a1b..fbcc9dd070d8 100644
--- a/app-arch/stormlib/Manifest
+++ b/app-arch/stormlib/Manifest
@@ -1 +1,2 @@
DIST StormLib-9.25.tar.gz 603875 BLAKE2B c7da242d039f5a49e8abd295b42e639fc540c77ee4bf8f210610d56940d1d35f19ea267dccde89e50f744218527f4c521e1d320f24e8fe3a0e0739ee899aa023 SHA512 0da78bda4bb89637da892fc73a0673b8a5f852ede4fdceba1029431d24dd1e59db9bfceafab1c5fb642e4b5d0d15d9865f7a138bfb190ce0c2d3601b22dd3023
+DIST StormLib-9.26.tar.gz 610223 BLAKE2B 670296e5d1f9d2b22d5f6cad214ff7076fdc5078c7aa6d13458e06b4b44b62acf2bd68689a05c630db024ea3d54bbc5be14855d757a1b31475664a593fb5db60 SHA512 5f0ce75019cfbe3a2dfc07ea312825e2babf226dbf8aa77ed60456862ae739ac4689cbe7d4a185cdc148ad9910fd8137d3f11c04ffe6c532bbdacb08838ecfba
diff --git a/app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch b/app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch
new file mode 100644
index 000000000000..95c46221fece
--- /dev/null
+++ b/app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch
@@ -0,0 +1,58 @@
+From 2e1e371c0a9eeaa015615b5a9f6826ec071a2e4a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 10 Jun 2024 14:41:37 +0200
+Subject: [PATCH] cmake: Use GNUInstallDirs for configurable install
+ directories
+
+Use the standard GNUInstallDirs CMake module to provide configurable
+install directories rather than hardcoding `bin`, `lib`, etc. Most
+importantly, this fixes install on modern 64-bit systems that use
+`lib64` rather than `lib`.
+---
+ CMakeLists.txt | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4758091..6546b69 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,7 @@ set(CMAKE_CXX_EXTENSIONS OFF)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+ include(CMakeDependentOption)
++include(GNUInstallDirs)
+
+ option(BUILD_SHARED_LIBS "Compile shared libraries" OFF)
+ option(STORM_SKIP_INSTALL "Skip installing files" OFF)
+@@ -360,14 +361,14 @@ endif()
+ if (NOT STORM_SKIP_INSTALL)
+ install(TARGETS ${LIBRARY_NAME}
+ EXPORT ${PROJECT_NAME}Config
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ FRAMEWORK DESTINATION /Library/Frameworks
+- PUBLIC_HEADER DESTINATION include
+- INCLUDES DESTINATION include)
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+- install(EXPORT ${PROJECT_NAME}Config NAMESPACE ${PROJECT_NAME}:: DESTINATION share/${PROJECT_NAME})
++ install(EXPORT ${PROJECT_NAME}Config NAMESPACE ${PROJECT_NAME}:: DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/${PROJECT_NAME})
+
+ #CPack configurtion
+ SET(CPACK_GENERATOR "DEB" "RPM")
+@@ -401,6 +402,6 @@ if(STORM_BUILD_TESTS)
+ find_package(ALSA REQUIRED)
+ add_executable(StormLib_test ${TEST_SRC_FILES})
+ target_link_libraries(StormLib_test ${LIBRARY_NAME} ${ALSA_LIBRARIES})
+- install(TARGETS StormLib_test RUNTIME DESTINATION bin)
++ install(TARGETS StormLib_test RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+
+--
+2.45.2
+
diff --git a/app-arch/stormlib/stormlib-9.26.ebuild b/app-arch/stormlib/stormlib-9.26.ebuild
new file mode 100644
index 000000000000..4987b7dfdfc8
--- /dev/null
+++ b/app-arch/stormlib/stormlib-9.26.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P=StormLib-${PV}
+DESCRIPTION="Library to read and write MPQ archives (Diablo, StarCraft)"
+HOMEPAGE="
+ http://www.zezula.net/en/mpq/stormlib.html
+ https://github.com/ladislav-zezula/StormLib/
+"
+SRC_URI="
+ https://github.com/ladislav-zezula/StormLib/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libtomcrypt:=[libtommath]
+ sys-libs/zlib:=
+"
+DEPEND=${RDEPEND}
+
+PATCHES=(
+ # https://github.com/ladislav-zezula/StormLib/pull/352
+ "${FILESDIR}/${P}-gnuinstalldirs.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ # interactive test app
+ -DSTORM_BUILD_TESTS=OFF
+ -DWITH_LIBTOMCRYPT=ON
+ )
+
+ cmake_src_configure
+}