summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-15 09:58:19 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-15 09:59:46 +0200
commit683780129630d693bb614c41f885946dcb885831 (patch)
tree802e8cdda220af987496a7657940e4c4da8efa62 /app-arch
parentdev-python/pypugjs: Fix typo in SRC_URI tarball renaming (diff)
downloadgentoo-683780129630d693bb614c41f885946dcb885831.tar.gz
gentoo-683780129630d693bb614c41f885946dcb885831.tar.bz2
gentoo-683780129630d693bb614c41f885946dcb885831.zip
app-arch/arc: Fix building with CFLAGS=-fno-common
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://bugs.gentoo.org/show_bug.cgi?id=706714 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/arc/arc-5.21p.ebuild1
-rw-r--r--app-arch/arc/files/arc-5.21p-fno-common.patch34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/arc/arc-5.21p.ebuild b/app-arch/arc/arc-5.21p.ebuild
index 93335639d0e0..f62a74e54786 100644
--- a/app-arch/arc/arc-5.21p.ebuild
+++ b/app-arch/arc/arc-5.21p.ebuild
@@ -18,6 +18,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.21m-darwin.patch
"${FILESDIR}"/${PN}-5.21m-gentoo-fbsd.patch
"${FILESDIR}"/${PN}-5.21o-interix.patch
+ "${FILESDIR}"/${PN}-5.21p-fno-common.patch
)
src_prepare() {
diff --git a/app-arch/arc/files/arc-5.21p-fno-common.patch b/app-arch/arc/files/arc-5.21p-fno-common.patch
new file mode 100644
index 000000000000..5de65e341c70
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21p-fno-common.patch
@@ -0,0 +1,34 @@
+--- a/arc.h
++++ b/arc.h
+@@ -129,4 +129,8 @@
+ extern u_short olddate; /* old archive date stamp */
+ extern u_short oldtime; /* old archive time stamp */
+ extern int dosquash; /* squash instead of crunch */
++extern long stdlen; /* bytes to read */
++extern u_char *outbuf;
++extern u_char *outend;
++extern short crcval; /* CRC check value */
+ #endif /* DONT_DEFINE */
+--- a/arclzw.c
++++ b/arclzw.c
+@@ -58,8 +58,7 @@
+
+ extern u_char *pinbuf;
+ u_char *inbeg, *inend;
+-u_char *outbuf;
+-u_char *outbeg, *outend;
++u_char *outbeg;
+
+ static int sp; /* current stack pointer */
+ static int inflag;
+--- a/arcunp.c
++++ b/arcunp.c
+@@ -39,8 +39,6 @@
+ #define NOHIST 0 /* no relevant history */
+ #define INREP 1 /* sending a repeated value */
+
+-short crcval; /* CRC check value */
+-long stdlen; /* bytes to read */
+ #if !DOS
+ static int gotcr; /* got a carriage return? */
+ #endif