summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-07-31 08:54:19 +0200
committerFabian Groffen <grobian@gentoo.org>2024-07-31 08:55:23 +0200
commite496d625bae691cc79b5b1c9f8c301a17c5cd46f (patch)
treea540a92a02c5db2424214cd767856ecf68367a03 /app-arch
parentsys-kernel/rt-sources: add 6.6.43_p38, drop 6.6.41_p37 (diff)
downloadgentoo-e496d625bae691cc79b5b1c9f8c301a17c5cd46f.tar.gz
gentoo-e496d625bae691cc79b5b1c9f8c301a17c5cd46f.tar.bz2
gentoo-e496d625bae691cc79b5b1c9f8c301a17c5cd46f.zip
app-arch/lz4-1.10.0-r1: add upstream approved patch for meson build
Disable forced C99 compiler mode, for it breaks on certain setups. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lz4/files/1.10.0-meson-do-not-force-c99-mode.patch44
-rw-r--r--app-arch/lz4/lz4-1.10.0-r1.ebuild1
2 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/lz4/files/1.10.0-meson-do-not-force-c99-mode.patch b/app-arch/lz4/files/1.10.0-meson-do-not-force-c99-mode.patch
new file mode 100644
index 000000000000..0d056b98833a
--- /dev/null
+++ b/app-arch/lz4/files/1.10.0-meson-do-not-force-c99-mode.patch
@@ -0,0 +1,44 @@
+https://github.com/lz4/lz4/pull/1485
+
+From bce6a94c25a9077fdcd7c94079a24f9713b192e1 Mon Sep 17 00:00:00 2001
+From: Fabian Groffen <grobian@gentoo.org>
+Date: Tue, 30 Jul 2024 21:50:06 +0200
+Subject: [PATCH] meson: do not force c99 mode
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+On Solaris/OpenIndiana hosts forcing (old) C99 means disabling POSIX
+2001 functionality, resulting in errors like
+
+In file included from ../../../net/ptah/export/gentoo/working-repos/lz4/programs/bench.c:39:
+../../../net/ptah/export/gentoo/working-repos/lz4/programs/util.h: In function UTIL_getOpenFileSize’:
+../../../net/ptah/export/gentoo/working-repos/lz4/programs/util.h:156:23: error: implicit declaration of function ‘fileno’ [-Wimplicit-function-declaration]
+ 156 | # define UTIL_fileno fileno
+ | ^~~~~~
+../../../net/ptah/export/gentoo/working-repos/lz4/programs/util.h:325:10: note: in expansion of macro ‘UTIL_fileno’
+ 325 | fd = UTIL_fileno(file);
+ | ^~~~~~~~~~~
+
+These can be fixed either by forcing a standard to be applied in programs/platform.h or by not forcing the compiler to use an old standard.
+
+Since CMake and Makefile don't force C99 by default either, just drop it from
+meson.build.
+
+Signed-off-by: Fabian Groffen <grobian@gentoo.org>
+---
+ build/meson/meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/build/meson/meson.build b/build/meson/meson.build
+index fc6408af6..7e1696802 100644
+--- a/build/meson/meson.build
++++ b/build/meson/meson.build
+@@ -16,7 +16,6 @@ project(
+ 'c',
+ license: 'BSD-2-Clause-Patent AND GPL-2.0-or-later',
+ default_options: [
+- 'c_std=c99',
+ 'buildtype=release',
+ 'warning_level=3'
+ ],
diff --git a/app-arch/lz4/lz4-1.10.0-r1.ebuild b/app-arch/lz4/lz4-1.10.0-r1.ebuild
index 7cbc02aadc78..c2b55ff90609 100644
--- a/app-arch/lz4/lz4-1.10.0-r1.ebuild
+++ b/app-arch/lz4/lz4-1.10.0-r1.ebuild
@@ -19,6 +19,7 @@ EMESON_SOURCE=${S}/build/meson
PATCHES=(
"${FILESDIR}/${PV}-fix-freestanding-test.patch"
+ "${FILESDIR}/${PV}-meson-do-not-force-c99-mode.patch"
)
multilib_src_configure() {