summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-22 22:21:36 +0000
committerMarek Szuba <marecki@gentoo.org>2023-03-22 23:43:28 +0000
commit87f254ade8929790e37c3fed8b3a6d0e061e9420 (patch)
tree280b39334d1b7fe6170a3dd5740a2df9b1e8552a /app-backup
parentdev-util/yamllint: Stabilize 1.29.0 ALLARCHES, #902769 (diff)
downloadgentoo-87f254ade8929790e37c3fed8b3a6d0e061e9420.tar.gz
gentoo-87f254ade8929790e37c3fed8b3a6d0e061e9420.tar.bz2
gentoo-87f254ade8929790e37c3fed8b3a6d0e061e9420.zip
app-backup/borgmatic: add 1.7.9
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.7.9.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index a7ac44d9c4df..f3713b0ebf3b 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
DIST borgmatic-1.7.5.tar.gz 338412 BLAKE2B e27fd709070a27c2ddd01fdfe23ef9caeb942c52d756332b4abd6d6cf39724656677a0d142a5392e35e0a0f25958421fe23edf04a252d212d761f48a0c320d9b SHA512 c27a364617e0e8fc1c11adac5375deac4e1663236a545d3fb70280974614d50ffe3821010ed5e4345afa3c3dab5f45c0d3bbfc946f50321601acb56965fd555d
DIST borgmatic-1.7.8.tar.gz 350233 BLAKE2B 3fcd392983f73ec5e97f0dc6b96e211d7f1e1d1a4ce95c635c675cf043e796925df53c30c1e4f8eb1a095d9ec5ff81e90edee5ff2576f4683053d3108004afd9 SHA512 bcc65fdb7ea1171fb61deda9b1f69a00596e1e10a99508d336977b694bd8f93d74837aad9211bf1065b785220aaf1460a3ea403bf23fa4873d1bf4c6b4016525
+DIST borgmatic-1.7.9.tar.gz 357158 BLAKE2B 8b95217c7c091ce3a1813ba0d19851fe63083a4a66ff4bee4aee6a5c67c552f27aad222d84608f82a67edf746934825a4545b552205d3a7e5a6615d9b17783a3 SHA512 f8e3a2d00897a83c2e27a896864e9c09998580ee37a18530d575f357d117928e0d6219d21025176873bd7e636aaa48fdf6d5f70e0c4f5a28fa198eccc84b84c0
diff --git a/app-backup/borgmatic/borgmatic-1.7.9.ebuild b/app-backup/borgmatic/borgmatic-1.7.9.ebuild
new file mode 100644
index 000000000000..0e099af68ef8
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.7.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.3-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}