summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2025-01-20 11:07:30 +0100
committerPetr Vaněk <arkamar@gentoo.org>2025-01-20 11:09:38 +0100
commitdb78d971a539b5106dc5718433b75ca38927cca8 (patch)
treedb3d2811f4440a7ca073dbfbe273c3eb0259fef2 /app-backup
parentdev-libs/xmlsec: Stabilize 1.3.6 amd64, #948434 (diff)
downloadgentoo-db78d971a539b5106dc5718433b75ca38927cca8.tar.gz
gentoo-db78d971a539b5106dc5718433b75ca38927cca8.tar.bz2
gentoo-db78d971a539b5106dc5718433b75ca38927cca8.zip
app-backup/borgmatic: add 1.9.6
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.9.6.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 8d9d5e1a70dd..cd806a7fca65 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,4 @@
DIST borgmatic-1.9.3.tar.gz 645018 BLAKE2B ae069bece54d80eab080cb30d4fb4b523cc7f31ca5d434a7f2fdfc8447ab72e6687fc6775a7811e15f120a0ad57284c539813c07b5cb258a2acf92e02dd55999 SHA512 22624e1a4454660288a3019513509006b389aafd657a45fa9e24c0b13b6a1266450c5b4ed531be5d8574c5f5fa5b869cb6860273f5d3d9a53b4e41474fb1b90e
DIST borgmatic-1.9.4.tar.gz 635562 BLAKE2B aac7cea7c7b9537a1f13f6cdd5fc15c3a7d439f9c609a3b05aeb0c10a844f479f0f3a1ec9470283b38594646985cc87c45445602e264f2e8fbabb509691feab4 SHA512 db258ebaa87ac88873c73ab750b7f72278376679c3641c91f4d3565d690a9cb25be5df94bb94aead83f09b27a1d41edbb7e457261440c33fddc9fde3477e7006
DIST borgmatic-1.9.5.tar.gz 638074 BLAKE2B 9947a443bcdd04abe29a3eaf3f790491cddc8283d6e09b56cb3b2aed97e0a424e0251aa9b19b3b5687416f59dec2944ed6d41c99df6e7790fa54a5b2608af0bf SHA512 9ab23865aeef61399a85532450cf7c9bc853a95560d383c83d43966eba0a66718976abdfcb2feec104c8941c0acd5406e2f1812be31b0f4baa76caf6a8ae81c9
+DIST borgmatic-1.9.6.tar.gz 640257 BLAKE2B 6d95fe1d12fa401b25d00187a20520003ebc05ceb481add6c0706fcc6bb40f275830cd35f3fa90ea3680457e93a33bf21abb7f3d6423c9268c95b4e356587fdc SHA512 ff2050dcde579e5dffeef915bead5672158387c9a883d9f5b996ba8e804e37d9445b07839f84959cae2b367735f742cab83e143b363cedbb61f38621e2b0a95b
diff --git a/app-backup/borgmatic/borgmatic-1.9.6.ebuild b/app-backup/borgmatic/borgmatic-1.9.6.ebuild
new file mode 100644
index 000000000000..dea28ebb55e3
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.9.6.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="
+ https://torsion.org/borgmatic/
+ https://projects.torsion.org/borgmatic-collective/borgmatic
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="
+ app-backup/borgbackup
+ $(python_gen_cond_dep '
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.9.3-no_test_coverage.patch
+)
+
+EPYTEST_DESELECT=(
+ # A fragile test whose only purpose is to make sure the NEWS file
+ # has been updated for the current version.
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.9.0; then
+ ewarn "Please be warned that ${PN}-1.9.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.9.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+}