summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2024-12-22 08:22:12 -0500
committerRichard Freeman <rich0@gentoo.org>2024-12-22 08:22:57 -0500
commitf91422a8a99106cab72a91f38bd3e23cf8bbf51c (patch)
tree1e7e17df6cbc3cd7ef1aef69664fc5f7a3640a31 /app-backup
parentnet-misc/nextcloud-client: fix patch filename (diff)
downloadgentoo-f91422a8a99106cab72a91f38bd3e23cf8bbf51c.tar.gz
gentoo-f91422a8a99106cab72a91f38bd3e23cf8bbf51c.tar.bz2
gentoo-f91422a8a99106cab72a91f38bd3e23cf8bbf51c.zip
app-backup/duplicity: add 3.0.3.2
Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-3.0.3.2.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-3.0.3.2-fix-docs-cmd.patch21
3 files changed, 73 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 5805f501b73a..f3c47640d441 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,3 +1,4 @@
DIST duplicity-2.2.3.tar.gz 1978008 BLAKE2B 29a88eb059c3dd6faa7d08d52216cd0f9d96255eae1e613e2c5432bf8f36ad014484953e20b4a0dfaa2704dd6ac426a3285ff40a8cc82f287a8a89199df5a2c5 SHA512 b667092317899674c5e9d4b221815f24a7eae177d3d2b6d298f07d3e2d4a7badd6c976a6317331b7c6cea940a7885a3da397ab7197d5fd671d33278316f86916
DIST duplicity-3.0.0.tar.gz 1943808 BLAKE2B 880f3944de7599c6e730f8b37f40d086d7332e7c8f5885e8477bf46b00832675eb89cbf58944f1134f8ab40ecadc4ae7b159131ebca0a910be4975f0510620da SHA512 59c19ffd46057b519f73f6e3715d6d8790d435966da66c1ea368e35217244fa478f9f1b8be96edbe081f7844d0dd497ec2b55efc1b8b4c6ca5a8d2c5e78a1a44
DIST duplicity-3.0.2.tar.gz 1933597 BLAKE2B 690d55e7e83d9834d2772be3845b88f9cde0d2190dbd78090661d5aeeaaa7f30a240c59187a74a1feb4f9167936a0fc63c5b13d0b13eecdbcd2d7175b416e5a1 SHA512 b174fdb793b8d6c1ba99a0e77d8c9cb2cbba6000d2a230be9cd894042d62be76ffe1fa5088121932abba394f03681318de6c906baf7383cb1b7e39e321c9f6fc
+DIST duplicity-3.0.3.2.tar.gz 1929330 BLAKE2B 00c33519edca5eb4f4468cf510381b8177a042d86eb1256105c61b42a7e712bad7b57f4a23997d1c85d0ccddb758f53e88fa0d1725fc8fe054a1a54f82cb64c8 SHA512 6c7917fede2b049ef1c6c49778a38dd8bb100cece2f66e49b311057400bca6dc3396ae0598176ec478ad9f0fbc6c896f06fe46b90e3ac0469fb6d5d2ad8bcaab
diff --git a/app-backup/duplicity/duplicity-3.0.3.2.ebuild b/app-backup/duplicity/duplicity-3.0.3.2.ebuild
new file mode 100644
index 000000000000..025ba02b2fce
--- /dev/null
+++ b/app-backup/duplicity/duplicity-3.0.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 python3_13 )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-3.0.3.2-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-3.0.3.2-fix-docs-cmd.patch
new file mode 100644
index 000000000000..9836217b394d
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-3.0.3.2-fix-docs-cmd.patch
@@ -0,0 +1,21 @@
+--- a/setup.py 2024-12-22 08:12:58.285362768 -0500
++++ b/setup.py 2024-12-22 08:13:31.138806077 -0500
+@@ -113,18 +113,6 @@
+ "man/duplicity.1",
+ ],
+ ),
+- (
+- f"share/doc/duplicity-{Version}",
+- [
+- "CHANGELOG.md",
+- "AUTHORS.md",
+- "COPYING",
+- "README.md",
+- "README-LOG.md",
+- "README-REPO.md",
+- "README-TESTING.md",
+- ],
+- ),
+ ]
+
+ # short circuit fot READTHEDOCS