summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/tiobench/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/tiobench/files')
-rw-r--r--app-benchmarks/tiobench/files/0.3.3-LDFLAGS.patch12
-rw-r--r--app-benchmarks/tiobench/files/0.3.3-column-description-fix.patch21
-rw-r--r--app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch21
3 files changed, 54 insertions, 0 deletions
diff --git a/app-benchmarks/tiobench/files/0.3.3-LDFLAGS.patch b/app-benchmarks/tiobench/files/0.3.3-LDFLAGS.patch
new file mode 100644
index 000000000000..9145ae47044a
--- /dev/null
+++ b/app-benchmarks/tiobench/files/0.3.3-LDFLAGS.patch
@@ -0,0 +1,12 @@
+diff -Nur tiobench-0.3.3.orig/Makefile tiobench-0.3.3/Makefile
+--- tiobench-0.3.3.orig/Makefile 2002-03-13 20:22:55.000000000 +0000
++++ tiobench-0.3.3/Makefile 2006-09-16 17:07:21.181644608 +0000
+@@ -34,7 +34,7 @@
+ $(CC) -c $(CFLAGS) $(DEFINES) tiotest.c -o tiotest.o
+
+ $(EXE): tiotest.o crc32.o
+- $(LINK) -o $(EXE) tiotest.o crc32.o -lpthread
++ $(LINK) -o $(EXE) $(LDFLAGS) tiotest.o crc32.o -lpthread
+ @echo
+ @echo "./tiobench.pl --help for usage options"
+ @echo
diff --git a/app-benchmarks/tiobench/files/0.3.3-column-description-fix.patch b/app-benchmarks/tiobench/files/0.3.3-column-description-fix.patch
new file mode 100644
index 000000000000..b3ebb90b33e1
--- /dev/null
+++ b/app-benchmarks/tiobench/files/0.3.3-column-description-fix.patch
@@ -0,0 +1,21 @@
+--- tiobench.pl 2005-02-23 00:21:33.000000000 +0100
++++ tiobench.pl 2005-03-15 18:11:19.000000000 +0100
+@@ -168,6 +168,8 @@
+ $stat_data{$identifier}{$thread}{$size}{$block}{$field}{'stime'} ) /
+ $stat_data{$identifier}{$thread}{$size}{$block}{$field}{'time'};
+ $stat_data{$identifier}{$thread}{$size}{$block}{$field}{'cpueff'} =
++ ($stat_data{$identifier}{$thread}{$size}{$block}{$field}{'cpu'} == 0) ?
++ '0' :
+ ($stat_data{$identifier}{$thread}{$size}{$block}{$field}{'rate'} /
+ ($stat_data{$identifier}{$thread}{$size}{$block}{$field}{'cpu'}/100));
+ }
+@@ -196,6 +198,9 @@
+ $report{'SEQ_WRITES'} = "Sequential Writes";
+ $report{'RAND_WRITES'} = "Random Writes";
+
++# The top is the same for all 4 reports
++$^ = 'SEQ_READS_TOP';
++
+ foreach my $title ('SEQ_READS', 'RAND_READS', 'SEQ_WRITES', 'RAND_WRITES') {
+ $-=0; $~="$title"; $^L=''; # reporting variables
+ print "\n$report{$title}\n";
diff --git a/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch b/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch
new file mode 100644
index 000000000000..fed845a51d62
--- /dev/null
+++ b/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch
@@ -0,0 +1,21 @@
+diff -Nur tiobench-0.3.3.orig/tiotest.c tiobench-0.3.3/tiotest.c
+--- tiobench-0.3.3.orig/tiotest.c 2001-03-05 02:34:00.000000000 +0000
++++ tiobench-0.3.3/tiotest.c 2012-11-04 22:44:41.695677071 +0000
+@@ -31,7 +31,7 @@
+ */
+ ArgumentOptions args;
+
+-static void * aligned_alloc(ssize_t size)
++static void * tio_aligned_alloc(ssize_t size)
+ {
+ caddr_t a;
+ a = mmap((caddr_t )0, size,
+@@ -281,7 +281,7 @@
+ pthread_attr_setscope(&(d->threads[i].thread_attr),
+ PTHREAD_SCOPE_SYSTEM);
+
+- d->threads[i].buffer = aligned_alloc( d->threads[i].blockSize );
++ d->threads[i].buffer = tio_aligned_alloc( d->threads[i].blockSize );
+ if( d->threads[i].buffer == NULL )
+ {
+ perror("Error allocating memory");