summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-15 21:25:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-15 22:07:06 +0200
commit09b70192c9f942afe91495d6fbef3d1a72c191fb (patch)
treece1369625c21fb7701c373cee0253ca7f1bb0632 /app-cdr/dolphin-plugins-mountiso
parentkde-apps/umbrello: 23.08.1 version bump (diff)
downloadgentoo-09b70192c9f942afe91495d6fbef3d1a72c191fb.tar.gz
gentoo-09b70192c9f942afe91495d6fbef3d1a72c191fb.tar.bz2
gentoo-09b70192c9f942afe91495d6fbef3d1a72c191fb.zip
app-cdr/dolphin-plugins-mountiso: 23.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr/dolphin-plugins-mountiso')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.08.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index 09e4ebe4aa75..07721def80e7 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8
DIST dolphin-plugins-23.08.0.tar.xz 273412 BLAKE2B edd20bb433b5288cc5687009cfd65d978b98de6b81dbc9b8aeb598a84411f67557e72be5212844852ce4cd7ecdd9d092e003603dfe8e6b6a5a2a30d94fbb3f58 SHA512 4abf6e41c6a4755117446ac744779ca7acdf1f1380cffa5be9931fc1463073b20c3c0b26a20de86befb49541f04523aedb8114189d68413bb75317d98ee54615
+DIST dolphin-plugins-23.08.1.tar.xz 273396 BLAKE2B e65c161d992867c2934581ea3e92b457eddc30b193cdb92d49bc820b2d4a6069dc6b25f1fbfe0871ca6fe0548511ceb4a3045c8a0204a8a25a656bd030bb3fad SHA512 8266810d249c70e3c5e874d87caa4e2aa5960c7e35ecb39b39845f2e225adbccf6f92b3fce4e03a5383d3bbc13b140f039d7ba7678616a670e347f6798520a48
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.08.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.08.1.ebuild
new file mode 100644
index 000000000000..34df875e54e2
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.08.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}