summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2025-02-02 10:18:32 +0200
committerJoonas Niilola <juippis@gentoo.org>2025-02-02 10:18:32 +0200
commit0b4f73b2089b8582a12cc384173049454cfbe2aa (patch)
tree0f591978594e6d4aae15c721027b494ae4289f8f /app-containers
parentmedia-video/yle-dl: stabilize 20250126 for ALLARCHES (diff)
downloadgentoo-0b4f73b2089b8582a12cc384173049454cfbe2aa.tar.gz
gentoo-0b4f73b2089b8582a12cc384173049454cfbe2aa.tar.bz2
gentoo-0b4f73b2089b8582a12cc384173049454cfbe2aa.zip
app-containers/incus: add upstream patch to 6.9 for 'incus file pull'
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/incus/files/incus-6.9-ensure-leading-slash-in-all-paths.patch32
-rw-r--r--app-containers/incus/incus-6.9-r1.ebuild (renamed from app-containers/incus/incus-6.9.ebuild)2
2 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/incus/files/incus-6.9-ensure-leading-slash-in-all-paths.patch b/app-containers/incus/files/incus-6.9-ensure-leading-slash-in-all-paths.patch
new file mode 100644
index 000000000000..a4647528c593
--- /dev/null
+++ b/app-containers/incus/files/incus-6.9-ensure-leading-slash-in-all-paths.patch
@@ -0,0 +1,32 @@
+From b726905c66050ac4229d53ce079a0bd05dbe900d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?St=C3=A9phane=20Graber?= <stgraber@stgraber.org>
+Date: Thu, 30 Jan 2025 15:21:36 +0100
+Subject: [PATCH] incus/file/pull: Ensure we have a leading / in all paths
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Closes #1614
+
+Signed-off-by: Stéphane Graber <stgraber@stgraber.org>
+---
+ cmd/incus/file.go | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/cmd/incus/file.go b/cmd/incus/file.go
+index a17486ad327..99467a0bfc5 100644
+--- a/cmd/incus/file.go
++++ b/cmd/incus/file.go
+@@ -575,6 +575,11 @@ func (c *cmdFilePull) Run(cmd *cobra.Command, args []string) error {
+ return fmt.Errorf(i18n.G("Invalid source %s"), resource.name)
+ }
+
++ // Make sure we have a leading / for the path.
++ if !strings.HasPrefix(pathSpec[1], "/") {
++ pathSpec[1] = "/" + pathSpec[1]
++ }
++
+ sftpConn, ok := sftpClients[pathSpec[0]]
+ if !ok {
+ sftpConn, err = resource.server.GetInstanceFileSFTP(pathSpec[0])
+
diff --git a/app-containers/incus/incus-6.9.ebuild b/app-containers/incus/incus-6.9-r1.ebuild
index fa843c98a152..2554cf605f8b 100644
--- a/app-containers/incus/incus-6.9.ebuild
+++ b/app-containers/incus/incus-6.9-r1.ebuild
@@ -91,6 +91,8 @@ RESTRICT="test"
GOPATH="${S}/_dist"
+PATCHES=( "${FILESDIR}"/incus-6.9-ensure-leading-slash-in-all-paths.patch )
+
src_unpack() {
verify-sig_src_unpack
go-module_src_unpack