summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2024-05-16 23:49:07 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-06-28 10:43:34 +0300
commit78a80d67558ed5ae0f14ba8ecb8bee5d9aadd329 (patch)
tree9c0d961676ed54bc4b9988fdb04358181b7a7538 /app-containers
parentdev-db/litecli: add 1.11.0 (diff)
downloadgentoo-78a80d67558ed5ae0f14ba8ecb8bee5d9aadd329.tar.gz
gentoo-78a80d67558ed5ae0f14ba8ecb8bee5d9aadd329.tar.bz2
gentoo-78a80d67558ed5ae0f14ba8ecb8bee5d9aadd329.zip
app-containers/docker-buildx: Bump to 0.14.0
Closes: https://bugs.gentoo.org/929033 Signed-off-by: Gergely Nagy <ngg@ngg.hu> Closes: https://github.com/gentoo/gentoo/pull/36706 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-buildx/Manifest1
-rw-r--r--app-containers/docker-buildx/docker-buildx-0.14.0.ebuild62
-rw-r--r--app-containers/docker-buildx/docker-buildx-9999.ebuild5
3 files changed, 66 insertions, 2 deletions
diff --git a/app-containers/docker-buildx/Manifest b/app-containers/docker-buildx/Manifest
index 810b0bff9ca8..c9a6377e58d8 100644
--- a/app-containers/docker-buildx/Manifest
+++ b/app-containers/docker-buildx/Manifest
@@ -1,2 +1,3 @@
DIST docker-buildx-0.10.4.tar.gz 9184825 BLAKE2B f0e71c0f6dda5f02da4cf0b0514f67f5d339ba10359afc69aae25abf907447fd22fe3d92427299bc67aeaa6a84e748a8a5cbd86151b2baba2dd01f25cc04a793 SHA512 f82b89b8dd4e45524c8d353c4d7588f47b1c7b7ecf759fd9605247c1c7aa0ca152c3ecdec0e0b62b5eef05e6b65d2ca1f5ccab6d75819b92fc92ff62b44105b7
DIST docker-buildx-0.11.2.tar.gz 10342565 BLAKE2B 1e034e9a07f36b46096f8f035869adc93b63af46cd9886f5ed4bc0939ce2f76b7f029a11ee536a34be23952e5c85251d757cec9ff05df172e3a26ea82a1bf0b1 SHA512 6f3718edf1e86c4422e1419580e4c38cf378a59555067be2aa6fac3e7f8878afe39d777765ace274cd9c47630f39cbacfacfdc4ecadd6ff46d5ee37d8f9bc75c
+DIST docker-buildx-0.14.0.tar.gz 11120356 BLAKE2B 01fec6b29665088a4778cb6a926f071c1beacb22d7a50593d55afff1225d0e74d083a82eaab4ae96ffee8a6f653ce048fd81b3410e7113bc29da210d77042b64 SHA512 bc09f29096cfd08c60efd8fca7976a1db896f0ed08d33dfc64dfca2c6487a1dc1722b3fe80b6a175ebebeacf8b460bcc214806d0c7a637f17ed5d09793d8c9d8
diff --git a/app-containers/docker-buildx/docker-buildx-0.14.0.ebuild b/app-containers/docker-buildx/docker-buildx-0.14.0.ebuild
new file mode 100644
index 000000000000..d36ee06a5456
--- /dev/null
+++ b/app-containers/docker-buildx/docker-buildx-0.14.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+MY_PN="buildx"
+DESCRIPTION="Docker CLI plugin for extended build capabilities with BuildKit"
+HOMEPAGE="https://github.com/docker/buildx"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/docker/buildx.git"
+else
+ SRC_URI="https://github.com/docker/buildx/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="test"
+
+# This gives us the ability to neatly `-skip` tests.
+# not required once ::gentoo is all > 1.20
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( >=dev-lang/go-1.20 )
+"
+RDEPEND="app-containers/docker-cli"
+
+src_compile() {
+ local _buildx_r='github.com/docker/buildx'
+ local version=${PV}
+ if [[ ${PV} == 9999 ]]; then
+ version="$(git rev-parse --short HEAD)"
+ fi
+ ego build -o docker-buildx \
+ -ldflags "-linkmode=external
+ -X $_buildx_r/version.Version=${version}
+ -X $_buildx_r/version.Revision=$(date -u +%FT%T%z)
+ -X $_buildx_r/version.Package=$_buildx_r" \
+ ./cmd/buildx
+}
+
+src_test() {
+ # TestGit can't work in a source tarball; TestReadTargets fails seemingly due to parallelism.
+ if [[ ${PV} == 9999 ]]; then
+ ego test ./... -skip "TestReadTargets|TestIntegration"
+ else
+ ego test ./... -skip "TestGit|TestReadTargets|TestIntegration"
+ fi
+}
+
+src_install() {
+ exeinto /usr/libexec/docker/cli-plugins
+ doexe docker-buildx
+
+ dodoc README.md
+}
diff --git a/app-containers/docker-buildx/docker-buildx-9999.ebuild b/app-containers/docker-buildx/docker-buildx-9999.ebuild
index 8cecb6eed7ae..d36ee06a5456 100644
--- a/app-containers/docker-buildx/docker-buildx-9999.ebuild
+++ b/app-containers/docker-buildx/docker-buildx-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,10 +20,11 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
+IUSE="test"
+
# This gives us the ability to neatly `-skip` tests.
# not required once ::gentoo is all > 1.20
RESTRICT="!test? ( test )"
-IUSE="test"
BDEPEND="
test? ( >=dev-lang/go-1.20 )