summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-14 15:55:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-14 16:08:11 +0200
commitf30250df6a4b58b63af83f24b2974713381e9d9e (patch)
treeea373c2785ddb58f6a5693431352fe5b84f53787 /app-containers
parentapp-containers/docker-pushrm: new package; add 1.9.0 (diff)
downloadgentoo-f30250df6a4b58b63af83f24b2974713381e9d9e.tar.gz
gentoo-f30250df6a4b58b63af83f24b2974713381e9d9e.tar.bz2
gentoo-f30250df6a4b58b63af83f24b2974713381e9d9e.zip
app-containers/earthly: drop old 0.8.13
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.13.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 8bf9e73f799d..01cc96748ada 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,5 +1,3 @@
-DIST earthly-0.8.13-deps.tar.xz 163750220 BLAKE2B 995ed748f99b7d4c4ca90cdd1964c295270963e55462bfa3bdd830209a90303d67c91fed66e7d52984993ef58b1d060e140694fdc8931ca2181dd88701d8f6dd SHA512 ab3ee4fef9a87dab9009ffd4e31d00a256c8ad88096c8573a5a2fb782079392415752024821240da60549d260c9dcfe3d6f1457fb3fbc8cc8a1f2602bb875aee
-DIST earthly-0.8.13.tar.gz 8082676 BLAKE2B cf6d5c6d397951a60302e5492ad219d3d673cce9bf2e06696a3cd8719dcf1d755644413171c7db1b27c60d6cbe0d85facf2d6a5d150c26dc5530c07d1255b742 SHA512 f3abd814c0c57f485a37c83e322d9a8478236ae4220baf455330a6a28d98a8cb7806fb4cee9525c9b27c51bc0ed8780872f51ece7194059658defd54cce1a6b5
DIST earthly-0.8.14-deps.tar.xz 163777848 BLAKE2B 0615db6d874a0d490666df6517581763315c44a67662d1c8c630d59983849c3a1c10bdee4d626f9ded02a58f7eb037e24cca6b22dfc7eadf79d4e735a33306c5 SHA512 ac062ae77e98ec36f9bba1a73430080d2f2c7bed3ad8c48af8bb1da4a6f006a4285fca8f4d85363652ec3db9df78e76befdfc838971684d704512d795d672414
DIST earthly-0.8.14.tar.gz 8079338 BLAKE2B c3da74c39b77f671656ba51f7e8a82b77476650e986e5665e1df86fd1674e808b79edcc0b8f616891b6749ec034de45268fb48df519c5fdf54c1e3e583eab5a6 SHA512 566e6bdd6f026baa99bad33128e3a843ef20dacc15efdccaf19af648440c8ee7b445bed80f33102b9fc419d211dc6dea38a66655247549f1eaf17837c6687105
DIST earthly-0.8.15-deps.tar.xz 163782812 BLAKE2B 09a9cb196206e787a48c2c2082a066a31c0bd8dba8785e379bfb86ac56ccf4f8eb34195c8577b866bc1153657008e4fae142eb7a6e21d2791fe92e9cdfa76e2d SHA512 65afc0bd89b6a54bb3e4cc4d7f39522eddbb79266b25afb33ffc3c6571b57952bc2ceafe00ce196098d1c4185ab2672f8a80d9ecd4d6d07dc06a18ba39da3941
diff --git a/app-containers/earthly/earthly-0.8.13.ebuild b/app-containers/earthly/earthly-0.8.13.ebuild
deleted file mode 100644
index ebee46234ccf..000000000000
--- a/app-containers/earthly/earthly-0.8.13.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
-if [[ "${PV}" == "0.8.13" ]] ; then
- COMMIT_SHA="251e0eada58646e71c562b803bc4b9adbcf07637"
-else
- die 'Could not detect "COMMIT_SHA", please update the ebuild.'
-fi
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local -r go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${COMMIT_SHA}
- -X main.Version=v${PV}
- "
- local -a -r go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o ./bin/
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}