summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 01:45:09 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 03:30:49 +0200
commit5fae3d8f587470b03e9be2de0cf038d72dc84504 (patch)
tree50565c7719f102f9934177b731d05931ff13142b /app-crypt/bsign
parentapp-crypt/tc-play: eapi bump (diff)
downloadgentoo-5fae3d8f587470b03e9be2de0cf038d72dc84504.tar.gz
gentoo-5fae3d8f587470b03e9be2de0cf038d72dc84504.tar.bz2
gentoo-5fae3d8f587470b03e9be2de0cf038d72dc84504.zip
app-crypt/bsign: eapi bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-crypt/bsign')
-rw-r--r--app-crypt/bsign/bsign-0.4.5-r1.ebuild19
-rw-r--r--app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch8
2 files changed, 16 insertions, 11 deletions
diff --git a/app-crypt/bsign/bsign-0.4.5-r1.ebuild b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
index c2b4476d4cd2..2431d369e7f5 100644
--- a/app-crypt/bsign/bsign-0.4.5-r1.ebuild
+++ b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit autotools flag-o-matic eutils toolchain-funcs
+EAPI=6
+inherit autotools flag-o-matic
DESCRIPTION="embed secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files"
HOMEPAGE="http://packages.debian.org/sid/bsign"
@@ -14,10 +14,15 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86 ~x86-linux"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-scripts.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
- epatch "${FILESDIR}"/${P}-build.patch
- epatch "${FILESDIR}"/${P}-scripts.patch
+ default
+ mv configure.in configure.ac
eautoreconf
}
@@ -27,8 +32,8 @@ src_configure() {
}
src_install() {
+ einstalldocs
dobin bsign_sign bsign_verify bsign_hash bsign_check
newbin o/bsign-unstripped bsign
doman bsign.1
- dodoc README
}
diff --git a/app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch b/app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch
index b07d78450ee1..3ba133b4f869 100644
--- a/app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch
+++ b/app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch
@@ -1,5 +1,5 @@
---- Makefile.in
-+++ Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -62,7 +62,7 @@
#LFLAGS=-g @LDFLAGS@ @LIBS@
#LFLAGS=-pg ${LFLAGS}
@@ -14,12 +14,12 @@
.version: .version_major .version_minor .version_patch
- @/bin/echo -n `cat .version_major`.`cat .version_minor`.`cat \
-+ @echo -n `cat .version_major`.`cat .version_minor`.`cat \
++ @printf "%s" `cat .version_major`.`cat .version_minor`.`cat \
.version_patch` > .version
_version.h: .version
- @/bin/echo -e \#define SZ_VERSION \"`cat .version`\" > _version.h
-+ @echo -e \#define SZ_VERSION \"`cat .version`\" > _version.h
++ @echo "#define SZ_VERSION \"`cat .version`\"" > _version.h
.PHONY: transmit
transmit: # distribution-archive