summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2022-02-15 15:11:15 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2022-02-15 15:17:12 -0500
commita8b4e336f1685176f62c62ab38d34e8dc2e9a9cb (patch)
tree968222cafa791037bc37f75634441f520cfeaae9 /app-crypt/jitterentropy
parentapp-text/nuspell: 5.1.0 (diff)
downloadgentoo-a8b4e336f1685176f62c62ab38d34e8dc2e9a9cb.tar.gz
gentoo-a8b4e336f1685176f62c62ab38d34e8dc2e9a9cb.tar.bz2
gentoo-a8b4e336f1685176f62c62ab38d34e8dc2e9a9cb.zip
app-crypt/jitterentropy: append -O0 to CPPFLAGS #833256
The upstream doesn't allow any code optimizations and handles CFLAGS accordingly. Handle CPPFLAGS in the ebuild by explicitly appending it with '-O0'. Closes: https://bugs.gentoo.org/833256 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/jitterentropy')
-rw-r--r--app-crypt/jitterentropy/jitterentropy-3.3.1.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy/jitterentropy-3.3.1.ebuild b/app-crypt/jitterentropy/jitterentropy-3.3.1.ebuild
index c089421d22ee..4f867c12ca00 100644
--- a/app-crypt/jitterentropy/jitterentropy-3.3.1.ebuild
+++ b/app-crypt/jitterentropy/jitterentropy-3.3.1.ebuild
@@ -34,6 +34,9 @@ src_compile() {
# This allows those default flags to be overwritten by
# user-defined CFLAGS. Restore some of the defaults.
append-cflags '-fwrapv' '-fvisibility=hidden' '-fPIE'
+ # Optimizations are not allowed by upstream, which already
+ # overrides CFLAGS in Makefile. We need to handle CPPFLAGS here.
+ append-cppflags '-O0'
emake AR="$(tc-getAR)" CC="$(tc-getCC)"
}