summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2023-12-03 16:43:34 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-02-01 10:28:17 +0200
commit82d17ecf3c2a5544c4a29a75702f403251bbdd58 (patch)
tree3325ffde0c4a35ec53114c3cfbab50ea2fc4dcc2 /app-crypt/loop-aes-losetup
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-82d17ecf3c2a5544c4a29a75702f403251bbdd58.tar.gz
gentoo-82d17ecf3c2a5544c4a29a75702f403251bbdd58.tar.bz2
gentoo-82d17ecf3c2a5544c4a29a75702f403251bbdd58.zip
app-crypt/loop-aes-losetup: add 2.39.2
Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/870745 Closes: https://github.com/gentoo/gentoo/pull/34121 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/loop-aes-losetup')
-rw-r--r--app-crypt/loop-aes-losetup/Manifest2
-rw-r--r--app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/app-crypt/loop-aes-losetup/Manifest b/app-crypt/loop-aes-losetup/Manifest
index c0368113e3f3..8fcc8786a4f9 100644
--- a/app-crypt/loop-aes-losetup/Manifest
+++ b/app-crypt/loop-aes-losetup/Manifest
@@ -1,2 +1,4 @@
DIST loop-AES-v3.7q.tar.bz2 376027 BLAKE2B 7f3206196fcb7ecc928bda4cd127042f61cd5ac7f39e483fb91db388572be1c8e252d5c4adb653e6fd00ff6a7ba4c1406c35f2b2659e9cb38fd817f1bdb2a15f SHA512 103869695f6b18bcc765804865468db4b24fc2fcce3ec97d8468fdc0bd37c480386960730e280cd93c707026dddc5e79d8d25e2601c3678330e016835166ad20
DIST util-linux-2.35.2.tar.xz 5150488 BLAKE2B 93eb90ab33db7795b46425ec4ec87f8a2d3d6e0dad671345375ea02efd654bf72041932d30b41bea494e4b62952e2fd14ea9f9e6c738d4eb4b050bd170b9bb0e SHA512 59e038ba71aa74c9af6f927b357483a965f675ab3ffcd25cf0c1b043656312d2d2d07c55659fd3da69ede165bec313e0ae7e1cd73758e49681ae610604b399a2
+DIST util-linux-2.39.2.tar.xz 8362220 BLAKE2B 963c257b86f8a025a3452f102656f479382b9e03dd8ce39b9561302b484c595005aa0bbce9b91422d9be038037143772483363c2a1eec569355316fc8d5d5765 SHA512 cebecdd62749d0aeea2c4faf7ad1606426eff03ef3b15cd9c2df1126f216a4ed546d8fc3218c649fa95944eb87a98bb6a7cdd0bea31057c481c5cf608ffc19a3
+DIST loop-AES-v3.8b.tar.bz2 411795 BLAKE2B 51e2c4ddd25f288c5cc5cbbbe20d79951d68bc2b7ecc91fe6eddbb829b297fe6946590512f423efcf5be3c4a1c9ce450c0cf49ed44ac6ad8eb2568468570d48f SHA512 8143649cc9616735cb9a9c8cb8b5c8a709b139e8b41aec444d56c85ef7852d103f657d0d702ffb04783963f0d0e919a6fe4e10b31cd373cd326e546caad90661
diff --git a/app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild
new file mode 100644
index 000000000000..7551cf619b3e
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs libtool flag-o-matic
+
+MY_PV="${PV/_/-}"
+MY_P="util-linux-${MY_PV}"
+LOOPAES_P="loop-AES-v3.8b"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Loop-AES losetup utility"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/util-linux/util-linux"
+SRC_URI="https://www.kernel.org/pub/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz
+ http://loop-aes.sourceforge.net/loop-AES/${LOOPAES_P}.tar.bz2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+
+LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
+SLOT="0"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( >=sys-libs/libselinux-2.2.2-r4 )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+"
+
+PATCHES=(
+ "${WORKDIR}/${LOOPAES_P}/util-linux-${PV}.diff"
+)
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ append-lfs-flags
+
+ # The scanf test in a run-time test which fails while cross-compiling.
+ # Blindly assume a POSIX setup since we require libmount, and libmount
+ # itself fails when the scanf test fails. #531856
+ tc-is-cross-compiler && export scanf_cv_alloc_modifier=ms
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-all-programs \
+ --disable-libmount-mountfd-support \
+ --disable-pylibmount \
+ --enable-libsmartcols \
+ --enable-losetup \
+ --without-ncurses \
+ --without-udev \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use_enable static) \
+ $(use static && echo --enable-static-programs=losetup)
+}
+
+src_install() {
+ emake install DESTDIR="${T}/root"
+ newsbin "${T}/root/sbin/losetup" loop-aes-losetup
+ newman "${T}/root/usr/share/man/man8/losetup.8" loop-aes-losetup.8
+ use static && newsbin "${T}/root/bin/losetup.static" loop-aes-losetup.static
+}