summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 14:43:06 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 14:52:07 +0100
commitfa42c6a17859db00095f18fd3a90bf9e271485c6 (patch)
tree0914416c73c4e8e8dd73e125dc3ccf06c604cca6 /app-crypt/seahorse
parentnet-vpn/networkmanager-openvpn: Bump to 1.8.16 (diff)
downloadgentoo-fa42c6a17859db00095f18fd3a90bf9e271485c6.tar.gz
gentoo-fa42c6a17859db00095f18fd3a90bf9e271485c6.tar.bz2
gentoo-fa42c6a17859db00095f18fd3a90bf9e271485c6.zip
app-crypt/seahorse: Bump to 41.0
Closes: https://bugs.gentoo.org/793416 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest1
-rw-r--r--app-crypt/seahorse/seahorse-41.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index 1493076949f5..2446da87b272 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1 +1,2 @@
DIST seahorse-40.0.tar.xz 1309064 BLAKE2B dd179ef13c79454b30571959b33c02a523591fa9d59957e0c30ec5d75a52bd8e9a5b420214f85d5feac0849d69a51ddcee808ab47e4bf97d7ac99094f853bc9a SHA512 c389420fb1b3d54c1b9a1004f2c8b9e50118a1ffcba02aa8cfdd2223d1bc117368c9a1ad875c59abd319d95eb93ec3de2e9cedadbfc1d6a0997d613c8256c60b
+DIST seahorse-41.0.tar.xz 1371984 BLAKE2B fdfc7c6d5ba41ab83c639d93c92fe6e1c36d42a02c7a384c2055bfe594e2a16415115bfb07597de93a886e492974e38c812fbbd59c7112c0360adeed96cb437d SHA512 cc51e27a55ed646ee376aa1b1bffe28369d80e4b8c484c9711de6bdf190694714ef208579d0399b5c199b5619491d72dede1b1f6c03b89cf3a53e8519a4d4fcf
diff --git a/app-crypt/seahorse/seahorse-41.0.ebuild b/app-crypt/seahorse/seahorse-41.0.ebuild
new file mode 100644
index 000000000000..ffb7491746a0
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-41.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Manage your passwords and encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.66:2
+ >=app-crypt/gcr-3.38:=
+ >=app-crypt/gpgme-1.14.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=app-crypt/gnupg-2.2
+ >=gui-libs/libhandy-1.1:1=
+ >=app-crypt/libsecret-0.16
+ dev-libs/libpwquality
+ net-misc/openssh
+ ldap? ( net-nds/openldap:= )
+ >=net-libs/libsoup-2.33.92:2.4
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxml2:2
+ app-crypt/gcr[vala]
+ app-crypt/libsecret[vala]
+ gui-libs/libhandy:1[vala]
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Dpgp-support=true
+ -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
+ -Dpkcs11-support=true
+ -Dkeyservers-support=true
+ -Dhkp-support=true
+ $(meson_use ldap ldap-support)
+ $(meson_use zeroconf key-sharing)
+ -Dmanpage=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}