summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-07 11:52:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-07 11:52:50 -0500
commit1c6d473cbdce63cdd870c54c4933222ed7714311 (patch)
tree5cdfcc5493a7f05799a9450dcf55c395b375738e /app-crypt/stoken
parentsys-libs/ntdb: softening blocker with agreement from the samba team (diff)
downloadgentoo-1c6d473cbdce63cdd870c54c4933222ed7714311.tar.gz
gentoo-1c6d473cbdce63cdd870c54c4933222ed7714311.tar.bz2
gentoo-1c6d473cbdce63cdd870c54c4933222ed7714311.zip
app-crypt/stoken: packaging for bug 539660
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-crypt/stoken')
-rw-r--r--app-crypt/stoken/Manifest1
-rw-r--r--app-crypt/stoken/metadata.xml11
-rw-r--r--app-crypt/stoken/stoken-0.90.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/stoken/Manifest b/app-crypt/stoken/Manifest
new file mode 100644
index 000000000000..322dddaa761c
--- /dev/null
+++ b/app-crypt/stoken/Manifest
@@ -0,0 +1 @@
+DIST v0.90.tar.gz 116642 SHA256 45912c200e2bcf0d605ba4b1177fbc9191cfd0ca509dd33075fd7ba17ebd6dda SHA512 7c75a04ea6542a13d639bbb74523443e030559dcf65d181d07fc64277442500a8a18daf2351248a552e42daf815fe5d0079b5b559402522d45ac10ed7762c818 WHIRLPOOL cfeb2bf9ac173a5416a08c99405bdc2ea0feff10cb040ffe5e89fc95c570da369d85fc5679fdedcdb017fdfcc89374dfd8544f519b6df587cad7b4e7bc113f8e
diff --git a/app-crypt/stoken/metadata.xml b/app-crypt/stoken/metadata.xml
new file mode 100644
index 000000000000..adcd617a5a14
--- /dev/null
+++ b/app-crypt/stoken/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ stoken is an open source tokencode generator compatible with RSA SecurID 128-bit (AES) tokens. It is a hobbyist project, not affiliated with or endorsed by RSA Security.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-crypt/stoken/stoken-0.90.ebuild b/app-crypt/stoken/stoken-0.90.ebuild
new file mode 100644
index 000000000000..e2ca5a126f61
--- /dev/null
+++ b/app-crypt/stoken/stoken-0.90.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="stoken - Software Token for Linux/UNIX"
+HOMEPAGE="http://stoken.sourceforge.net/"
+SRC_URI="http://github.com/cernekee/stoken/archive/v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with gtk)
+}
+
+src_install() {
+ default
+ dodoc CHANGES COPYING.LIB README.md TODO
+ doman stoken.1
+ if use gtk ; then
+ doman stoken-gui.1
+ fi
+}