summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-29 14:08:48 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-29 14:08:48 +0200
commit82c1657e6087a9ec05c52ca98a220b2c089f000f (patch)
treef2ca3fe56cdf3c421f2fd3a65e15c01b599d07d3 /app-crypt/yubioath-desktop
parentapp-crypt/yubikey-manager: add 4.0.5 (diff)
downloadgentoo-82c1657e6087a9ec05c52ca98a220b2c089f000f.tar.gz
gentoo-82c1657e6087a9ec05c52ca98a220b2c089f000f.tar.bz2
gentoo-82c1657e6087a9ec05c52ca98a220b2c089f000f.zip
app-crypt/yubioath-desktop: initial import
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/yubioath-desktop')
-rw-r--r--app-crypt/yubioath-desktop/Manifest1
-rw-r--r--app-crypt/yubioath-desktop/metadata.xml8
-rw-r--r--app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild52
3 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/yubioath-desktop/Manifest b/app-crypt/yubioath-desktop/Manifest
new file mode 100644
index 000000000000..79259f2181a8
--- /dev/null
+++ b/app-crypt/yubioath-desktop/Manifest
@@ -0,0 +1 @@
+DIST yubioath-desktop-5.0.5.tar.gz 5659179 BLAKE2B 31dd1a7e9b8a5034e916f38c7893572b6b7e75fa0bc45b5b807c89010ac0e4a01a446f03d1591dd6323a015fc8fb17861fa60dc5a5e4eff40b5261fb6e3f7088 SHA512 b5a0df306916896e1fd84d6a794a43365b0e0a2cecd97ec1dacc6312507dd2e4dd55fc12b0de9d72d1d0a1b40625330373b7c74dacb2ec37a24ea3e1fd2d4ff7
diff --git a/app-crypt/yubioath-desktop/metadata.xml b/app-crypt/yubioath-desktop/metadata.xml
new file mode 100644
index 000000000000..70f78a5392df
--- /dev/null
+++ b/app-crypt/yubioath-desktop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild b/app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild
new file mode 100644
index 000000000000..67898ac59b24
--- /dev/null
+++ b/app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit desktop python-single-r1 qmake-utils xdg
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey NEO"
+HOMEPAGE="
+ https://developers.yubico.com/yubioath-desktop/
+ https://github.com/Yubico/yubioath-desktop"
+SRC_URI="https://github.com/Yubico/yubioath-desktop/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ x11-libs/libdrm"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '>=app-crypt/yubikey-manager-4.0.0[${PYTHON_USEDEP}]')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:python build_qrc.py:${PYTHON} build_qrc.py:" \
+ yubioath-desktop.pro || die
+
+ python_fix_shebang "${S}"
+}
+
+src_configure() {
+ eqmake5 yubioath-desktop.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ domenu resources/com.yubico.yubioath.desktop
+ doicon resources/icons/com.yubico.yubioath.png
+ doicon -s scalable resources/icons/com.yubico.yubioath.svg
+}