summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-08-20 23:00:08 -0400
committerMatt Turner <mattst88@gentoo.org>2023-08-20 23:23:44 -0400
commit0c197700e049e2e1807148aea7abd9081ffb5f4f (patch)
tree6a1f159f5474833480111d6a5fb2110dc7ffca30 /app-crypt
parentdev-python/poetry: Bump to 1.6.0 (diff)
downloadgentoo-0c197700e049e2e1807148aea7abd9081ffb5f4f.tar.gz
gentoo-0c197700e049e2e1807148aea7abd9081ffb5f4f.tar.bz2
gentoo-0c197700e049e2e1807148aea7abd9081ffb5f4f.zip
app-crypt/libsecret: Version bump to 0.21.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libsecret/Manifest1
-rw-r--r--app-crypt/libsecret/libsecret-0.21.0.ebuild154
2 files changed, 155 insertions, 0 deletions
diff --git a/app-crypt/libsecret/Manifest b/app-crypt/libsecret/Manifest
index 0c168c61d169..e4b2cf12cc01 100644
--- a/app-crypt/libsecret/Manifest
+++ b/app-crypt/libsecret/Manifest
@@ -1 +1,2 @@
DIST libsecret-0.20.5.tar.xz 187340 BLAKE2B cde5094eaaf54f251c19afb015c39cc88435dafe6ee682ca8f9d1917dd5b3dc8cc1609cdbf2a3a42d2592c2a149bec5fe28b2f4ec179b92c0d0f07d2f14c1792 SHA512 61ca248aafd265e1f31d56c9084c68d880ebf03660ace3d4a6c6622ab306b56e921ac24647b6a60633bfa99c8a0407d4ae1aa6148511f289bf5ce2025b72692a
+DIST libsecret-0.21.0.tar.xz 190320 BLAKE2B 0775f1b80eea303793aa9c1e940e0cb47ada4cee10ebae947a7e17d5a749736a3219a7edf937693b32df5505c2dd96bffc523b4cfcb41c6a7f12cea0b43449b3 SHA512 666a67f3f06274ab57e1b6e3e855033ce244ab45b9b237851fc06f33ef7922179b5bcbe96a5dc50d1136cbb8d74c2d0af0af4d0ae9de918b4a63b36abb1f2b97
diff --git a/app-crypt/libsecret/libsecret-0.21.0.ebuild b/app-crypt/libsecret/libsecret-0.21.0.ebuild
new file mode 100644
index 000000000000..2bd69b9e0890
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.21.0.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 gnome2 meson-multilib python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+
+IUSE="+crypt gtk-doc +introspection test test-rust tpm +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ vala? ( introspection )
+ gtk-doc? ( crypt )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0=[${MULTILIB_USEDEP}] )
+ tpm? ( >=app-crypt/tpm2-tss-3.0.3:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="virtual/secret-service"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gi-docgen-2021.7
+ )
+ test? (
+ $(python_gen_any_dep '
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ introspection? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )')
+ test-rust? ( introspection? ( >=dev-libs/gjs-1.32 ) )
+ tpm? (
+ app-crypt/swtpm
+ app-crypt/tpm2-abrmd
+ >=app-crypt/tpm2-tss-3.2.0:=
+ )
+ )
+ vala? ( $(vala_depend) )
+"
+
+dbus_run() {
+ (
+ # start isolated dbus session bus
+ dbus_data=$(dbus-launch --sh-syntax) || exit
+ eval "${dbus_data}"
+
+ $@
+ ret=${?}
+
+ kill "${DBUS_SESSION_BUS_PID}"
+ exit "${ret}"
+ ) || die
+}
+
+tpm2_run_with_emulator() {
+ export XDG_CONFIG_HOME=${T}/.config/swtpm
+ "${BROOT}"/usr/share/swtpm/swtpm-create-user-config-files --overwrite || die
+
+ mkdir -p ${XDG_CONFIG_HOME}/mytpm1 || die
+ swtpm_setup_args=(
+ --tpm2
+ --tpmstate ${XDG_CONFIG_HOME}/mytpm1
+ --createek
+ --allow-signing
+ --decryption
+ --create-ek-cert
+ --create-platform-cert
+ --lock-nvram
+ --overwrite
+ --display
+ )
+ swtpm_setup "${swtpm_setup_args[@]}" || die
+
+ swtpm_socket_args=(
+ --tpm2
+ --tpmstate dir=${XDG_CONFIG_HOME}/mytpm1
+ --flags startup-clear
+ --ctrl type=unixio,path=${XDG_CONFIG_HOME}/mytpm1/swtpm.socket.ctrl
+ --server type=unixio,path=${XDG_CONFIG_HOME}/mytpm1/swtpm.socket
+ --pid file=${XDG_CONFIG_HOME}/mytpm1/swtpm.pid
+ --daemon
+ )
+ swtpm socket "${swtpm_socket_args[@]}" || die
+
+ tpm2_abrmd_args=(
+ --logger=stdout
+ --tcti=swtpm:path=${XDG_CONFIG_HOME}/mytpm1/swtpm.socket
+ --session
+ --flush-all
+ )
+ tpm2-abrmd "${tpm2_abrmd_args[@]}" &
+ export TCTI=tabrmd:bus_type=session
+
+ $@ || die
+
+ # When swtpm dies, tmp2-abrmd will exit
+ kill $(< ${XDG_CONFIG_HOME}/mytpm1/swtpm.pid) || die
+}
+
+python_check_deps() {
+ if use introspection; then
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+ fi
+ python_has_version "dev-python/mock[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_setup
+ default
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_true manpage)
+ $(meson_use crypt gcrypt)
+ $(meson_native_use_bool vala vapi)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_native_use_bool introspection)
+ -Dbashcompdir="$(get_bashcompdir)"
+ $(meson_native_enabled bash_completion)
+ $(meson_native_use_bool tpm tpm2)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ if use tpm; then
+ dbus_run tpm2_run_with_emulator virtx meson test -C "${BUILD_DIR}"
+ else
+ virtx dbus-run-session meson test -C "${BUILD_DIR}"
+ fi
+}