summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-02-22 10:32:27 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-22 10:39:55 +0100
commit4ed52b9c5eb59eed048a25b32513996708bbe82f (patch)
treeea3d56531dcfb9db3b98f84b597a94eab10d5d5a /app-crypt
parentapp-crypt/sequoia-sq: drop bash-completion-r1 since it is provided by shell-c... (diff)
downloadgentoo-4ed52b9c5eb59eed048a25b32513996708bbe82f.tar.gz
gentoo-4ed52b9c5eb59eed048a25b32513996708bbe82f.tar.bz2
gentoo-4ed52b9c5eb59eed048a25b32513996708bbe82f.zip
app-crypt/sequoia-sq: use ASSET_OUT_DIR
Of course, I discovered ASSET_OUT_DIR after implementing the workaround. Bug: https://bugs.gentoo.org/923572 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.33.0.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.33.0.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.33.0.ebuild
index 48c388e8f150..7eb46bd190c2 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.33.0.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.33.0.ebuild
@@ -514,19 +514,13 @@ src_compile() {
}
src_install() {
- cargo_src_install
+ local asset_dir="${T}"/assets
- doman target/$(usex debug debug release)/build/sequoia-sq-*/out/man-pages/*.1
+ ASSET_OUT_DIR="${asset_dir}" cargo_src_install
- # Since 0.33 sequoia-sq creates two shell-completions/ directories
- # with indentical content. Select one of them. See also
- # https://bugs.gentoo.org/923572
- local completion_dirs=(
- $(ls -1d target/$(usex debug debug release)/build/sequoia-sq-*/out/shell-completions)
- )
- [[ ${#completion_dirs[@]} -lt 1 ]] && die "No completion directories found"
- local completion_dir="${completion_dirs[0]}"
+ doman "${asset_dir}"/man-pages/*
+ local completion_dir="${asset_dir}"/shell-completions
newbashcomp "${completion_dir}"/sq.bash sq
dozshcomp "${completion_dir}"/_sq
dofishcomp "${completion_dir}"/sq.fish