summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-09 14:45:45 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-09 14:45:45 +0200
commit8634e867df221165f30d7a130b266daafc17b7ca (patch)
treea6e5872c18edefaba679e3eccc94000ff1508794 /app-crypt
parentwww-servers/thttpd: remove unused file (diff)
downloadgentoo-8634e867df221165f30d7a130b266daafc17b7ca.tar.gz
gentoo-8634e867df221165f30d7a130b266daafc17b7ca.tar.bz2
gentoo-8634e867df221165f30d7a130b266daafc17b7ca.zip
app-crypt/gifshuffle: EAPI 6 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild (renamed from app-crypt/gifshuffle/gifshuffle-2.0.ebuild)10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-crypt/gifshuffle/gifshuffle-2.0.ebuild b/app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild
index 219f1830c348..c2a8cfb2d9de 100644
--- a/app-crypt/gifshuffle/gifshuffle-2.0.ebuild
+++ b/app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="GIF colourmap steganography"
@@ -15,14 +17,14 @@ IUSE=""
DEPEND=""
RDEPEND=""
-S="${WORKDIR}"/${PN}
+S="${WORKDIR}/${PN}"
src_compile() {
- echo $(tc-getCC) -o ${PN} ${CFLAGS} ${LDFLAGS} *.c
+ echo $(tc-getCC) -o ${PN} ${CFLAGS} ${LDFLAGS} *.c || die
$(tc-getCC) -o ${PN} ${CFLAGS} ${LDFLAGS} *.c || die "Cannot compile ${PN}"
}
src_install() {
- dobin ${PN} || die "Cannot install ${PN}"
+ dobin ${PN}
dodoc gshuf.txt
}