summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-16 18:45:44 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-15 10:27:38 +0300
commit934d766ed30001e2ccd3f142a7469a8cfde924bf (patch)
treec700aa800469aa1fd01cf8898d2f0d94e12d8c3d /app-dicts/dictd-vera
parentapp-editors/gummi: Bump to 0.8.2 (diff)
downloadgentoo-934d766ed30001e2ccd3f142a7469a8cfde924bf.tar.gz
gentoo-934d766ed30001e2ccd3f142a7469a8cfde924bf.tar.bz2
gentoo-934d766ed30001e2ccd3f142a7469a8cfde924bf.zip
app-dicts/dictd-vera: move data to /usr/share
Bug: https://bugs.gentoo.org/790383 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20842 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts/dictd-vera')
-rw-r--r--app-dicts/dictd-vera/dictd-vera-1.24-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-dicts/dictd-vera/dictd-vera-1.24-r1.ebuild b/app-dicts/dictd-vera/dictd-vera-1.24-r1.ebuild
new file mode 100644
index 000000000000..57e23417d5eb
--- /dev/null
+++ b/app-dicts/dictd-vera/dictd-vera-1.24-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
+HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
+SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
+S="${WORKDIR}/vera-${PV}"
+SLOT="0"
+LICENSE="FDL-1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-U+D7.patch" )
+
+src_compile() {
+ cat vera.[0-9a-z] | dictfmt -f -u http://home.snafu.de/ohei \
+ -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
+ vera || die
+ dictzip -v vera.dict || die
+}
+
+src_install() {
+ insinto /usr/share/dict
+ doins vera.dict.dz
+ doins vera.index
+
+ dodoc changelog README
+}