summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-07 13:13:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-07 13:44:04 +0200
commit07ab571614c969d11d540993fe8ed732f64deb41 (patch)
treecc86afd4f1276d64db45b165944a375da27b76ab /app-doc/python-docs
parentdev-lang/python: Bump to 3.9.20 (diff)
downloadgentoo-07ab571614c969d11d540993fe8ed732f64deb41.tar.gz
gentoo-07ab571614c969d11d540993fe8ed732f64deb41.tar.bz2
gentoo-07ab571614c969d11d540993fe8ed732f64deb41.zip
app-doc/python-docs: Bump to 3.9.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc/python-docs')
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.9.20.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index 24383c607fce..f464ddb8c9e1 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -9,3 +9,4 @@ DIST python-3.12.6-docs-html.tar.bz2 8360479 BLAKE2B 09294f5ba1ca8f53c0261e0db62
DIST python-3.8.19-docs-html.tar.bz2 6717842 BLAKE2B f5236daff937a03cffe6224610f4ebdf05516538b5cf38090de6d46d8a9626bf33ec1cd8408bcaaf2ad24591f48e9a5b3da831990b0706fb66321f09c2c05ed5 SHA512 188e41b681c0ec823de89ad0d408473bd7baff80c8ab4d691e2c8b1308a89af63c1973b8a3dac676b8b3880786e741355f653e67150e8170c27798b43a3462df
DIST python-3.8.20-docs-html.tar.bz2 6727651 BLAKE2B ec11857b5bdfb4646a2762353db877a558cfc543563a7a9b0db100f675511c31450d16c30a986d39226a9b16be3ffd132863e396ef05165047ab73bf037bf2a6 SHA512 0a77f0240d6d495a5099d4a95e151f38517730815e6f3d9b82964cf60be95b8bdc960916d317e19bb8e14a9604217cd1fa85703996aec972004a6a93d4ffa6d0
DIST python-3.9.19-docs-html.tar.bz2 6983522 BLAKE2B 4d70d134ff96aaed4c6d5c9ab7c59907cfb63b66c27be69c31324b49cf65c797aa160d7bfaf5f4e512391f8ba49fb88c7f470b7ef16d6f1e800c5073d5304a2f SHA512 5812613745d169caba35b234aeed77edcc1cd26d95a1cd32b0692bb7e27dc2acd9b94a45f349485856b9e4388b73f7b05d07b8626960f7127ba110f7094c5a48
+DIST python-3.9.20-docs-html.tar.bz2 6988218 BLAKE2B 0e463d8fa0643a9c01ba52d35c8880b00f5d4b83d778947937ac86e2db4f5af312d6d2b580ceb498db76c0ca61231befaf0fc6d1a17d8b1b84981ddea16bcebb SHA512 524ebdc8b082ba50691fb8eadf6bf17374a1d9d6e61a6b49efecf597bbd2c7b50bca908fb94c5ca9350c06895330d88086d0d1ee9ccb7306362b1cd37282a53d
diff --git a/app-doc/python-docs/python-docs-3.9.20.ebuild b/app-doc/python-docs/python-docs-3.9.20.ebuild
new file mode 100644
index 000000000000..8483ad559ab4
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.9.20.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}