summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-05 15:36:02 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-05 22:07:13 -0400
commit50152fe95541ba4a09233a3a59dda31a041e6251 (patch)
tree0aec2a9d1c9c00557ec9ba865ca54b381f62fe05 /app-editors/gnome-text-editor
parentapp-misc/gnote: Version bump to 43.0 (diff)
downloadgentoo-50152fe95541ba4a09233a3a59dda31a041e6251.tar.gz
gentoo-50152fe95541ba4a09233a3a59dda31a041e6251.tar.bz2
gentoo-50152fe95541ba4a09233a3a59dda31a041e6251.zip
app-editors/gnome-text-editor: Version bump to 43.1
Closes: https://github.com/gentoo/gentoo/pull/27634 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gnome-text-editor')
-rw-r--r--app-editors/gnome-text-editor/Manifest1
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-43.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index 209f8aebae03..74d995d675d4 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1,2 +1,3 @@
DIST gnome-text-editor-42.2.tar.xz 1168504 BLAKE2B 0bbd02fab92c3ac2df2a38352561dda27662b4ede30d9cfd05b54d58c4dc4824375ee427e764415dc450a2f8dd793ba539e5681df984a20b1d121bd97a3f3008 SHA512 4373b048118c7a4253fe99a6ec6091c054154399d34e5a33f933d535f0e6c659023603e08e1cbcddb972d6385632b2b9351455eaa1398dcd7c50b3b4562400ae
DIST gnome-text-editor-43.0.tar.xz 575536 BLAKE2B 7e99d63bc42e4a7327451a610bcf022f03f2bf1f4a1665655302fc5dbdf4811f8b828821a49fab4fa1afe3c77568d8cd87dcef97ca8201ff0bb6517f693688a1 SHA512 359287e3338531285110628df934ff9c81c236aec692c088084fd3c3944703ec9737f2f12554be477becf0d9a12706b621bd4558a54ebaf70f713c75a750b181
+DIST gnome-text-editor-43.1.tar.xz 601588 BLAKE2B 0e3b7231327898b554360cfa45c3ba9f8ff005f61b6f68f6ea431d1c9e459b429af4da794b06ce6f4618de06c96a191477f1cadd61cfa6ae9e1ae350b75658a1 SHA512 aab2fcf5d0ad705833802bec3ccacce175c16dc717b521e0b220ddf5420760ec76a90db9b4f4ee0722c2b19a40304e1c379f06f2983e4597df233ade67a0f725
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-43.1.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-43.1.ebuild
new file mode 100644
index 000000000000..69aa51a07264
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-43.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.73.0:2
+ >=gui-libs/gtk-4.7:4
+ >=gui-libs/gtksourceview-5.5.0:5
+ >=gui-libs/libadwaita-1.2:1
+ app-text/editorconfig-core-c
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ -Dbugreport_url="https://bugs.gentoo.org"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}