summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-10-01 09:33:17 +0200
committerUlrich Müller <ulm@gentoo.org>2022-10-01 09:41:53 +0200
commit405235cb0470d1c75f94cdddefe684dc4fbf3648 (patch)
tree08df71dcb46028c3df250ba696b2cc3485359d7c /app-editors/jupp/jupp-3.1_p41.ebuild
parentdev-ruby/rspec-support: add 3.11.1 (diff)
downloadgentoo-405235cb0470d1c75f94cdddefe684dc4fbf3648.tar.gz
gentoo-405235cb0470d1c75f94cdddefe684dc4fbf3648.tar.bz2
gentoo-405235cb0470d1c75f94cdddefe684dc4fbf3648.zip
app-editors/jupp: add 3.1_p41
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/jupp/jupp-3.1_p41.ebuild')
-rw-r--r--app-editors/jupp/jupp-3.1_p41.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-editors/jupp/jupp-3.1_p41.ebuild b/app-editors/jupp/jupp-3.1_p41.ebuild
new file mode 100644
index 000000000000..cfdbb37a9585
--- /dev/null
+++ b/app-editors/jupp/jupp-3.1_p41.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Portable version of Joe's Own Editor"
+HOMEPAGE="http://www.mirbsd.org/jupp.htm"
+SRC_URI="http://www.mirbsd.org/MirOS/dist/${PN}/joe-${PV/_p/${PN}}.tgz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses"
+
+RDEPEND="ncurses? ( sys-libs/ncurses:0= )
+ !app-editors/joe"
+DEPEND="${RDEPEND}"
+
+DOCS="HINTS INFO LIST NEWS README TODO"
+
+src_configure() {
+ chmod +x configure || die
+ econf \
+ --enable-search_libs \
+ --enable-termcap \
+ $(use_enable ncurses curses)
+}