summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-12-21 22:17:51 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2017-01-04 23:37:07 +0100
commit5ca3a30c0a1e7285d352b8e312e6e89091aecd69 (patch)
treecdb7564878ac57b56b72819f8405d2894a9884d5 /app-editors/latexila/latexila-3.22.1.ebuild
parentmedia-gfx/shotwell: bump to 0.24.3 (diff)
downloadgentoo-5ca3a30c0a1e7285d352b8e312e6e89091aecd69.tar.gz
gentoo-5ca3a30c0a1e7285d352b8e312e6e89091aecd69.tar.bz2
gentoo-5ca3a30c0a1e7285d352b8e312e6e89091aecd69.zip
app-editors/latexila: bump to 3.22.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3208 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-editors/latexila/latexila-3.22.1.ebuild')
-rw-r--r--app-editors/latexila/latexila-3.22.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-editors/latexila/latexila-3.22.1.ebuild b/app-editors/latexila/latexila-3.22.1.ebuild
new file mode 100644
index 000000000000..15ac698ad3da
--- /dev/null
+++ b/app-editors/latexila/latexila-3.22.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/LaTeXila"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +latexmk rubber"
+
+COMMON_DEPEND="
+ $(vala_depend)
+ app-text/enchant
+ >=app-text/gspell-1.0:0=
+ >=dev-libs/glib-2.40:2[dbus]
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/gtksourceview-3.18:3.0=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+}