summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianyang Zhou <qsdrqs@gmail.com>2022-05-31 18:25:56 -0700
committerSam James <sam@gentoo.org>2022-06-01 03:15:00 +0100
commit2f06c41edaa2b6454f430ca85511f25af26c314b (patch)
treecf9e757484179d7f2005161b588e77b5dfddf914 /app-editors/neovim/files
parentdev-db/redis: get rid of external Lua (diff)
downloadgentoo-2f06c41edaa2b6454f430ca85511f25af26c314b.tar.gz
gentoo-2f06c41edaa2b6454f430ca85511f25af26c314b.tar.bz2
gentoo-2f06c41edaa2b6454f430ca85511f25af26c314b.zip
app-editors/neovim: fix lua patch for neovim git
Signed-off-by: Tianyang Zhou <qsdrqs@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25714 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/neovim/files')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake_lua_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
new file mode 100644
index 000000000000..d7e01275fb02
--- /dev/null
+++ b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -384,7 +384,7 @@
+ option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
+
+ if(PREFER_LUA)
+- find_package(Lua 5.1 EXACT REQUIRED)
++ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
+ set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
+ set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
+ # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.